summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-06-24 07:27:17 +0200
committerHans de Graaff <graaff@gentoo.org>2023-06-24 07:52:55 +0200
commit00f32812948d76f65a2e68093b4fadff1e876e0a (patch)
treed8b1ac0b1bb42e403fb7bb718e36e497daa95299 /dev-ruby/rubypants
parentdev-ruby/ruby-shout: enable ruby32 (diff)
downloadgentoo-00f32812948d76f65a2e68093b4fadff1e876e0a.tar.gz
gentoo-00f32812948d76f65a2e68093b4fadff1e876e0a.tar.bz2
gentoo-00f32812948d76f65a2e68093b4fadff1e876e0a.zip
dev-ruby/rubypants: update EAPI 7 -> 8
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/rubypants')
-rw-r--r--dev-ruby/rubypants/rubypants-0.7.1-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/rubypants/rubypants-0.7.1-r1.ebuild b/dev-ruby/rubypants/rubypants-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..f6a6aeb5d440
--- /dev/null
+++ b/dev-ruby/rubypants/rubypants-0.7.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby port of the SmartyPants PHP library"
+HOMEPAGE="https://leahneukirchen.org/repos/rubypants/README"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/ecov/I s:^:#:' test/helper.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -I. test/rubypants_test.rb || die "tests failed"
+}