summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/rspec-support
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/rspec-support')
-rw-r--r--dev-ruby/rspec-support/Manifest2
-rw-r--r--dev-ruby/rspec-support/metadata.xml8
-rw-r--r--dev-ruby/rspec-support/rspec-support-3.2.1.ebuild43
-rw-r--r--dev-ruby/rspec-support/rspec-support-3.3.0.ebuild34
4 files changed, 87 insertions, 0 deletions
diff --git a/dev-ruby/rspec-support/Manifest b/dev-ruby/rspec-support/Manifest
new file mode 100644
index 000000000000..2b8f70f8974e
--- /dev/null
+++ b/dev-ruby/rspec-support/Manifest
@@ -0,0 +1,2 @@
+DIST rspec-support-3.2.1-git.tgz 38054 SHA256 5b4349b9139124d2dfc6900ddde20583503f2147b452b59afaf0a2ec858987a4 SHA512 2813bbd7c875aa3aa958e7ce0ac01f4ad19c581814369daee67d73130de0d0de136a78930ee2da38333892edd3e64bcdb67ac2f8ccd2fa468f4f8a99f96b1344 WHIRLPOOL 98e62fffe7c7f45769c1ec5751ad7b20884c3826183d773da5dc46f9c5652067472f00d1c24318ebd42ae23591c3d94c0e591777455e485b3826653a20c01867
+DIST rspec-support-3.3.0-git.tgz 45380 SHA256 cea58331f616e407c4ee25bb0b74bad26dbdc793fd341010d37749dea15e30a2 SHA512 88f0fdbc7609093c8f14bff220a03d0788847315e5ac73c025cd181d84a3ac120c294aca8ffff9a0c11c9f11e35019dc337f9e43fc2c33cabe4856d87e36fa1e WHIRLPOOL 6f355bb1dc71bbb7804fd3d4a4227042bbe0d166ef336e4121730abce52e1596b25b94ae38e72a6284ca2eac6d0eb6146a02f54d08792b1ff5a6320d40524a2a
diff --git a/dev-ruby/rspec-support/metadata.xml b/dev-ruby/rspec-support/metadata.xml
new file mode 100644
index 000000000000..c26f7310ae09
--- /dev/null
+++ b/dev-ruby/rspec-support/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">rspec/rspec-support</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/rspec-support/rspec-support-3.2.1.ebuild b/dev-ruby/rspec-support/rspec-support-3.2.1.ebuild
new file mode 100644
index 000000000000..43baa8506882
--- /dev/null
+++ b/dev-ruby/rspec-support/rspec-support-3.2.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="https://github.com/rspec/rspec-support"
+SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=dev-ruby/rspec-3.2.0:3 )"
+
+all_ruby_prepare() {
+ sed -i -e '/git ls-files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Remove spec that, by following symlinks, tries to scan pretty much
+ # the whole filesystem.
+ rm spec/rspec/support/caller_filter_spec.rb || die
+}
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *ruby22)
+ # The rubygems version bundled with ruby 2.2 causes warnings.
+ rm spec/rspec/support_spec.rb spec/rspec/support/spec/shell_out_spec.rb || die
+ ;;
+ esac
+}
diff --git a/dev-ruby/rspec-support/rspec-support-3.3.0.ebuild b/dev-ruby/rspec-support/rspec-support-3.3.0.ebuild
new file mode 100644
index 000000000000..8c6b23ecd1c1
--- /dev/null
+++ b/dev-ruby/rspec-support/rspec-support-3.3.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="https://github.com/rspec/rspec-support"
+SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=dev-ruby/rspec-3.3.0:3 )"
+
+all_ruby_prepare() {
+ sed -i -e '/git ls-files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Remove spec that, by following symlinks, tries to scan pretty much
+ # the whole filesystem.
+ rm spec/rspec/support/caller_filter_spec.rb || die
+}