summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-06-04 20:03:19 +0200
committerHans de Graaff <graaff@gentoo.org>2019-06-04 20:06:52 +0200
commitb89f9c6a2d2ad89b0848eaa470f564b6d14aeb5c (patch)
tree57a2f9a7a88387721b92394b29e1abf800ee1356 /dev-ruby/rex-exploitation
parentdev-ruby/autoprefixer-rails: add 9.6.0 (diff)
downloadgentoo-b89f9c6a2d2ad89b0848eaa470f564b6d14aeb5c.tar.gz
gentoo-b89f9c6a2d2ad89b0848eaa470f564b6d14aeb5c.tar.bz2
gentoo-b89f9c6a2d2ad89b0848eaa470f564b6d14aeb5c.zip
dev-ruby/rex-exploitation: add 0.1.21
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/rex-exploitation')
-rw-r--r--dev-ruby/rex-exploitation/Manifest1
-rw-r--r--dev-ruby/rex-exploitation/rex-exploitation-0.1.21.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/rex-exploitation/Manifest b/dev-ruby/rex-exploitation/Manifest
index 5b5098026d13..83da3323cf47 100644
--- a/dev-ruby/rex-exploitation/Manifest
+++ b/dev-ruby/rex-exploitation/Manifest
@@ -1,2 +1,3 @@
DIST rex-exploitation-0.1.19.gem 79360 BLAKE2B 47043054ee9d08775c67d54b31861ad3a454a487bdc47beb135942e267040de7611308c62a23cbf853d190fb8f88c52998dfe3b24f66a698e76e273b6a69d822 SHA512 244de5259e3f4f645df09d1843c34d9ea4f9ea56ba22498495792f192b79a0451810f5c7e73516da5a455c27e61b66f8ccfbc485372946fcedd179b75ff9b31e
DIST rex-exploitation-0.1.20.gem 79360 BLAKE2B 59dea65582647444e21cc1b0ae744c857b3007b8215c81244d37c6f3d8abcb1ef1b1d01428f306b4c5f6fdd1b3db0326de3c50fa38fa50505b4de9c05ba518e1 SHA512 e1df4ffde57ab40bf4b2492370d44bf064f39f657c7a8140416f51560a0be9b31ef95b1bdadaae6f6ec75c86e0978b41112a18caa1f69262c67945d3529f9990
+DIST rex-exploitation-0.1.21.gem 79360 BLAKE2B 78c31cf2255b8cc5fc9e7886d20bbad85f48877798ff68efaa72e22de9d62f3a78bc980a2ba1507e5aee6b35ba9fdc7b352f11985202584d10584fd84018f0bd SHA512 81cd2e8ab8a8230be66f8597a85894cf92e969c21864c04525eed93a614eb467e6ac6d1bb2bfc91ff68b1795be7a27c03c136c5976f9f76736e972bf2e7b890a
diff --git a/dev-ruby/rex-exploitation/rex-exploitation-0.1.21.ebuild b/dev-ruby/rex-exploitation/rex-exploitation-0.1.21.ebuild
new file mode 100644
index 000000000000..b729da79ae96
--- /dev/null
+++ b/dev-ruby/rex-exploitation/rex-exploitation-0.1.21.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="various helper mechanisms for creating exploits"
+HOMEPAGE="https://rubygems.org/gems/rex-exploitation"
+
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/jsobfu:*
+ dev-ruby/metasm:*
+ dev-ruby/rex-arch
+ dev-ruby/rex-encoder
+ dev-ruby/rex-text"
+
+all_ruby_prepare() {
+ sed -i '/bundler/d' Rakefile
+}