summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-02-09 10:10:15 +0100
committerHans de Graaff <graaff@gentoo.org>2024-02-09 10:13:50 +0100
commit12d733dbb55780dd082174b43e2d4c13f6a912ab (patch)
treeabb82d151dc4af0c618a08502660957bd83af840 /dev-ruby/rake
parentwww-client/qutebrowser: warn about qtwebengine[bindist] (diff)
downloadgentoo-12d733dbb55780dd082174b43e2d4c13f6a912ab.tar.gz
gentoo-12d733dbb55780dd082174b43e2d4c13f6a912ab.tar.bz2
gentoo-12d733dbb55780dd082174b43e2d4c13f6a912ab.zip
dev-ruby/rake: fix tests when rake is not installed
Ensure that the test suite uses the local files only, otherwise one of the tests will mysteriously fail when rake is not already installed. Also avoid loading minitest plugins which may break when rake is not present. Closes: https://bugs.gentoo.org/867652 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/rake')
-rw-r--r--dev-ruby/rake/rake-13.1.0.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-ruby/rake/rake-13.1.0.ebuild b/dev-ruby/rake/rake-13.1.0.ebuild
index 4ce7d447e2c7..2b254de6cfb7 100644
--- a/dev-ruby/rake/rake-13.1.0.ebuild
+++ b/dev-ruby/rake/rake-13.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -43,7 +43,7 @@ all_ruby_compile() {
}
each_ruby_test() {
- ${RUBY} -Ilib:test:. -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
+ MT_NO_PLUGINS=true RUBYLIB="$(pwd)/lib" ${RUBY} -Ilib:test:. -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
}
all_ruby_install() {