summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-05-01 06:43:28 +0200
committerHans de Graaff <graaff@gentoo.org>2018-05-01 06:43:28 +0200
commit7c00eef79213a2275ea57ee1e3faba95f24df349 (patch)
tree2d54daeb9f760a29e1e4c80b771f43dcfe5f562a /dev-ruby/pdf-core/pdf-core-0.8.1.ebuild
parentdev-ruby/patron: add 0.13.1 (diff)
downloadgentoo-7c00eef79213a2275ea57ee1e3faba95f24df349.tar.gz
gentoo-7c00eef79213a2275ea57ee1e3faba95f24df349.tar.bz2
gentoo-7c00eef79213a2275ea57ee1e3faba95f24df349.zip
dev-ruby/pdf-core: add 0.8.1
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-ruby/pdf-core/pdf-core-0.8.1.ebuild')
-rw-r--r--dev-ruby/pdf-core/pdf-core-0.8.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/pdf-core/pdf-core-0.8.1.ebuild b/dev-ruby/pdf-core/pdf-core-0.8.1.ebuild
new file mode 100644
index 000000000000..50cf1a76a97d
--- /dev/null
+++ b/dev-ruby/pdf-core/pdf-core-0.8.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implements low level PDF features for Prawn"
+HOMEPAGE="https://github.com/prawnpdf/pdf-core/"
+SRC_URI="https://github.com/prawnpdf/pdf-core/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( Ruby GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+ruby_add_bdepend "test? ( =dev-ruby/pdf-inspector-1*
+ >=dev-ruby/pdf-reader-1.2 =dev-ruby/pdf-reader-1* )"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" spec/spec_helper.rb || die
+}