summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-06-20 06:34:09 +0200
committerHans de Graaff <graaff@gentoo.org>2023-06-20 06:38:07 +0200
commit175fc249c3b324f8cbedc4e6fea14a092232f669 (patch)
tree6f9a8fe72bcea5f42fa1ed8301097c7fecc01a3d /dev-ruby/optimist
parentdev-perl/Math-BigInt-Lite: add 0.270.0 (diff)
downloadgentoo-175fc249c3b324f8cbedc4e6fea14a092232f669.tar.gz
gentoo-175fc249c3b324f8cbedc4e6fea14a092232f669.tar.bz2
gentoo-175fc249c3b324f8cbedc4e6fea14a092232f669.zip
dev-ruby/optimist: update EAPI 7 -> 8
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/optimist')
-rw-r--r--dev-ruby/optimist/optimist-3.0.1-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/optimist/optimist-3.0.1-r1.ebuild b/dev-ruby/optimist/optimist-3.0.1-r1.ebuild
new file mode 100644
index 000000000000..1abe03c9e1f4
--- /dev/null
+++ b/dev-ruby/optimist/optimist-3.0.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="FAQ.txt History.txt README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A commandline option parser for Ruby that just gets out of your way"
+HOMEPAGE="https://www.manageiq.org/optimist/"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos ~x64-macos ~x64-solaris"
+SLOT="3"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/chronic )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundle/ s:^:#:' Rakefile || die
+}
+
+each_ruby_test() {
+ MUTANT=true ${RUBY} -S rake test || die "Tests failed."
+}