summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-06-06 07:24:33 +0200
committerHans de Graaff <graaff@gentoo.org>2024-06-06 07:25:07 +0200
commit97c215fe5f9fe605695e496e3556d96b94163cd6 (patch)
tree011cfe3c23f549964308bee6ca3b3c1d068a0e97 /dev-ruby/minitest-around
parentgui-wm/wayfire: drop 0.8.1-r1 (diff)
downloadgentoo-97c215fe5f9fe605695e496e3556d96b94163cd6.tar.gz
gentoo-97c215fe5f9fe605695e496e3556d96b94163cd6.tar.bz2
gentoo-97c215fe5f9fe605695e496e3556d96b94163cd6.zip
dev-ruby/minitest-around: call the ruby version being tested
Bug: https://bugs.gentoo.org/928671 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/minitest-around')
-rw-r--r--dev-ruby/minitest-around/minitest-around-0.5.0-r1.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-ruby/minitest-around/minitest-around-0.5.0-r1.ebuild b/dev-ruby/minitest-around/minitest-around-0.5.0-r1.ebuild
index c1444d3859dc..f4b8a550ce61 100644
--- a/dev-ruby/minitest-around/minitest-around-0.5.0-r1.ebuild
+++ b/dev-ruby/minitest-around/minitest-around-0.5.0-r1.ebuild
@@ -29,6 +29,11 @@ all_ruby_prepare() {
-i test/helper.rb Rakefile || die
}
+each_ruby_prepare() {
+ sed -e "/spawn_test/,/^end/ s:ruby:${RUBY}:" \
+ -i test/around_spec.rb || die
+}
+
each_ruby_test() {
for f in test/*_{test,spec}.rb ; do
${RUBY} -S rake test:isolated TEST="${f}" || die