summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/memoizable
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/memoizable')
-rw-r--r--dev-ruby/memoizable/Manifest1
-rw-r--r--dev-ruby/memoizable/memoizable-0.4.2.ebuild30
-rw-r--r--dev-ruby/memoizable/metadata.xml8
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/memoizable/Manifest b/dev-ruby/memoizable/Manifest
new file mode 100644
index 000000000000..b9d642027567
--- /dev/null
+++ b/dev-ruby/memoizable/Manifest
@@ -0,0 +1 @@
+DIST memoizable-0.4.2.gem 13312 SHA256 acf4d2280fea019318e61cfc5e69077dcb3c2126817ee596ffd76d0ddf5e826c SHA512 6fa80eea7922bf93f9e2fcf88c0d0890e658820e8fdf9fc6bf7becf822435fbb95332a1d7b51aebb85018e787d87500899eb4d95f7467b6b2eb7c391c0e9583c WHIRLPOOL ecf2c72519236630db1ee579b89dbe0917ca180a3f2579390e548b8dd28d46082357801d63b3a698e1fca2089436fd4198a2545b0ef7ad655e158fbf261df97c
diff --git a/dev-ruby/memoizable/memoizable-0.4.2.ebuild b/dev-ruby/memoizable/memoizable-0.4.2.ebuild
new file mode 100644
index 000000000000..921243833d10
--- /dev/null
+++ b/dev-ruby/memoizable/memoizable-0.4.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Memoize method return values"
+HOMEPAGE="https://github.com/dkubb/memoizable"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/thread_safe-0.3.1:0"
+
+all_ruby_prepare() {
+ sed -i -e "/simplecov/,/^end$/d" spec/spec_helper.rb || die
+
+ # Avoid a failing test that also fails for upstream Travis.
+ rm spec/unit/memoizable/class_methods/included_spec.rb || die
+}
diff --git a/dev-ruby/memoizable/metadata.xml b/dev-ruby/memoizable/metadata.xml
new file mode 100644
index 000000000000..0ce3a519be49
--- /dev/null
+++ b/dev-ruby/memoizable/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">dkubb/memoizable</remote-id>
+ </upstream>
+</pkgmetadata>