summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-29 02:11:28 +0100
committerSam James <sam@gentoo.org>2023-03-29 13:55:57 +0100
commit78cbb18538d03852154e810bcbc07c92d15fed25 (patch)
tree08c64f8355221d2f38119a200561b54977dbfda9 /dev-ruby/httparty
parentdev-ruby/ox: drop 2.14.11, 2.14.12 (diff)
downloadgentoo-78cbb18538d03852154e810bcbc07c92d15fed25.tar.gz
gentoo-78cbb18538d03852154e810bcbc07c92d15fed25.tar.bz2
gentoo-78cbb18538d03852154e810bcbc07c92d15fed25.zip
dev-ruby/httparty: drop 0.20.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ruby/httparty')
-rw-r--r--dev-ruby/httparty/Manifest1
-rw-r--r--dev-ruby/httparty/httparty-0.20.0.ebuild61
2 files changed, 0 insertions, 62 deletions
diff --git a/dev-ruby/httparty/Manifest b/dev-ruby/httparty/Manifest
index 5cd616b80b71..701567b8a496 100644
--- a/dev-ruby/httparty/Manifest
+++ b/dev-ruby/httparty/Manifest
@@ -1,2 +1 @@
-DIST httparty-0.20.0.tar.gz 101975 BLAKE2B f15eb837a4bbc98de501e6dcca5a17bb0906e8ea6671c55a85d665659ab60bcee5e84d9dafad6b2450e22cedfaf5a86e10e077e52b1120ff9ae2613a1176a651 SHA512 f5770d5a64be2e80aa70334dad899fb723b08088a673a788ca1402285b77ae6b3cef21e3ed263d9618a32879711c9183f2dc82ff7b50bcf6439a8e6bb7a2eb4e
DIST httparty-0.21.0.tar.gz 102735 BLAKE2B 131c4f3a5a403b609391ececaf079de5ed5c57ea4660fc1d1041832d8baa27b8beaf11ac2743aa6059005904d787259afec27597744bb5e35e56c3b035ca4b1b SHA512 afd50de88a6b1e1cac8c90d6e1458c41ef122b4542c3a14274aacb052f9ceafad868d1b2582d45eedd212a8037fac13238ac05c2e661c9ba9196a00ef3a0a634
diff --git a/dev-ruby/httparty/httparty-0.20.0.ebuild b/dev-ruby/httparty/httparty-0.20.0.ebuild
deleted file mode 100644
index 9620611e560c..000000000000
--- a/dev-ruby/httparty/httparty-0.20.0.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-USE_RUBY="ruby26 ruby27 ruby30 ruby31"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_RECIPE_DOC="none"
-RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
-
-RUBY_FAKEGEM_GEMSPEC="httparty.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Makes http fun! Also, makes consuming restful web services dead easy"
-HOMEPAGE="https://jnunemaker.github.com/httparty"
-SRC_URI="https://github.com/jnunemaker/httparty/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-IUSE=""
-
-ruby_add_rdepend 'dev-ruby/mime-types:3 >=dev-ruby/multi_xml-0.5.2'
-
-ruby_add_bdepend 'test? ( dev-ruby/webmock )'
-
-all_ruby_prepare() {
- sed -i -e 's/git ls-files \?-\?-\?/find/' ${RUBY_FAKEGEM_GEMSPEC} || die
-
- # Remove bundler
- rm Gemfile || die
- sed -i -e '/[Bb]undler/ s:^:#:' Rakefile || die
-
- # Avoid test dependency on cucumber. We can't run the features since
- # they depend on mongrel which is no longer packaged.
- sed -i -e '/cucumber/I s:^:#:' Rakefile || die
-
- # Avoid test dependency on simplecov
- sed -i -e '/simplecov/I s:^:#:' \
- -e '/pry/ s:^:#:' \
- -e '1i require "cgi"; require "delegate"' spec/spec_helper.rb || die
-
- # Avoid test that works standalone but fails in the suite
- #sed -i -e '/calls block given to perform with each redirect/,/^ end/ s:^:#:' spec/httparty/request_spec.rb
-
- # Avoid test that is not fully compatible with newer multi_xml
- sed -i -e '/should be able parse response type xml automatically/askip "multi_xml"' spec/httparty_spec.rb || die
-
- # Avoid test that fails due to unicode normalization differences
- sed -i -e '/handles international domains/askip "unicode differences"' spec/httparty_spec.rb || die
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- docinto examples
- dodoc examples/*
-}