summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/http
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/http')
-rw-r--r--dev-ruby/http/Manifest3
-rw-r--r--dev-ruby/http/http-0.6.3-r1.ebuild28
-rw-r--r--dev-ruby/http/http-0.6.3.ebuild28
-rw-r--r--dev-ruby/http/http-0.8.12.ebuild35
-rw-r--r--dev-ruby/http/http-0.9.0.ebuild35
-rw-r--r--dev-ruby/http/metadata.xml8
6 files changed, 137 insertions, 0 deletions
diff --git a/dev-ruby/http/Manifest b/dev-ruby/http/Manifest
new file mode 100644
index 000000000000..b192ee117a39
--- /dev/null
+++ b/dev-ruby/http/Manifest
@@ -0,0 +1,3 @@
+DIST http-0.6.3.gem 67072 SHA256 bbefb6ab1255f2967437b0ea9b29058066c89b1e30448e3494ca3840432cb272 SHA512 e5fe784e833da30e5ef6bcdc43b45a04fcf03d827b8336853591c5ba67b5ccf45cc18849ec4a78f3a0526b05cc50da2a7aadd5ea211284fe73f8dddbe89c642b WHIRLPOOL e231732948a938310280ecdac254c98607a473d29e2ffbc9a36a9c0dc4144f5c54e8a52603581391eb6a5046e932d41817d57b516c8dcd4099c7fc8a2bcfe86f
+DIST http-0.8.12.gem 71168 SHA256 12a8a0f88f7edc70efe9c773dd6025ca70d9e1be24d18d37b2990be893d02713 SHA512 6e25b185092dec0f59f3bb6ee47817a3f53df4090fcb07cf163a39389732f3a13fde63c6eca93a3b0f3423640ea791585903a24a7339fe594a268c66aec3c51e WHIRLPOOL 83ca8abeb1f276832da544f3d15869576c2b14687e1db6b9026c3180a671f0598d1836e7f94f56e332f786dc36657344b63902663bcb85e98d534bbfdf7fd9a8
+DIST http-0.9.0.gem 64000 SHA256 1c24039281a60d6f072748e733a0540be6764e5a31d1d29fb6f8db3e9b67fe1d SHA512 344cf1d1940f5b24d83f6d0e832584d3a3e1cbe89ba0bc8dabfc1262a5b1924e1ff225c72dd699abfd351f8ca16209048d77702d4e5f603bbd6ca5682c810a47 WHIRLPOOL 5980b7ef5e196784aa6bd87e26e66c0eb453e4100ba2b742f4792a6d5a73e0b15200f0b559c15eb344db76c11135eb1a0c6e84eedf28d8080e8ac20f7caba6b0
diff --git a/dev-ruby/http/http-0.6.3-r1.ebuild b/dev-ruby/http/http-0.6.3-r1.ebuild
new file mode 100644
index 000000000000..66a38a8a5d99
--- /dev/null
+++ b/dev-ruby/http/http-0.6.3-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An easy-to-use client library for making requests from Ruby"
+HOMEPAGE="https://github.com/tarcieri/http"
+
+LICENSE="MIT"
+SLOT="0.6"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/http_parser_rb-0.6.0 =dev-ruby/http_parser_rb-0.6*"
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/,/end/ s:^:#:' \
+ -e '1irequire "cgi"' spec/spec_helper.rb || die
+}
diff --git a/dev-ruby/http/http-0.6.3.ebuild b/dev-ruby/http/http-0.6.3.ebuild
new file mode 100644
index 000000000000..d5fa39219e78
--- /dev/null
+++ b/dev-ruby/http/http-0.6.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An easy-to-use client library for making requests from Ruby"
+HOMEPAGE="https://github.com/tarcieri/http"
+
+LICENSE="MIT"
+SLOT="0.6"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/http_parser_rb-0.6.0 =dev-ruby/http_parser_rb-0.6*"
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/,/end/ s:^:#:' \
+ -e '1irequire "cgi"' spec/spec_helper.rb || die
+}
diff --git a/dev-ruby/http/http-0.8.12.ebuild b/dev-ruby/http/http-0.8.12.ebuild
new file mode 100644
index 000000000000..196ca4884993
--- /dev/null
+++ b/dev-ruby/http/http-0.8.12.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An easy-to-use client library for making requests from Ruby"
+HOMEPAGE="https://github.com/tarcieri/http"
+
+LICENSE="MIT"
+SLOT="0.8"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/addressable-2.3
+ >=dev-ruby/http-cookie-1.0
+ >=dev-ruby/http-form_data-1.0.1:1.0
+ >=dev-ruby/http_parser_rb-0.6.0 =dev-ruby/http_parser_rb-0.6*"
+
+ruby_add_bdepend "
+ test? ( dev-ruby/certificate_authority dev-ruby/rspec-its )"
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/,/end/ s:^:#:' \
+ -e '1irequire "cgi"' spec/spec_helper.rb || die
+}
diff --git a/dev-ruby/http/http-0.9.0.ebuild b/dev-ruby/http/http-0.9.0.ebuild
new file mode 100644
index 000000000000..196ca4884993
--- /dev/null
+++ b/dev-ruby/http/http-0.9.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An easy-to-use client library for making requests from Ruby"
+HOMEPAGE="https://github.com/tarcieri/http"
+
+LICENSE="MIT"
+SLOT="0.8"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/addressable-2.3
+ >=dev-ruby/http-cookie-1.0
+ >=dev-ruby/http-form_data-1.0.1:1.0
+ >=dev-ruby/http_parser_rb-0.6.0 =dev-ruby/http_parser_rb-0.6*"
+
+ruby_add_bdepend "
+ test? ( dev-ruby/certificate_authority dev-ruby/rspec-its )"
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/,/end/ s:^:#:' \
+ -e '1irequire "cgi"' spec/spec_helper.rb || die
+}
diff --git a/dev-ruby/http/metadata.xml b/dev-ruby/http/metadata.xml
new file mode 100644
index 000000000000..f48b570c1473
--- /dev/null
+++ b/dev-ruby/http/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">tarcieri/http</remote-id>
+ </upstream>
+</pkgmetadata>