summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-06-15 00:30:17 -0400
committerMatt Turner <mattst88@gentoo.org>2022-10-22 17:33:10 -0400
commit389795c71dbf91380aea5e10641b59eebc8bed30 (patch)
treeb5a7ea28ccf7cdd3badd514060c71661a34e4aee /dev-ruby/fiber-local
parentdev-ruby/ffi-compiler: revbump 1.0.1-r2, respect *FLAGS (diff)
downloadgentoo-389795c71dbf91380aea5e10641b59eebc8bed30.tar.gz
gentoo-389795c71dbf91380aea5e10641b59eebc8bed30.tar.bz2
gentoo-389795c71dbf91380aea5e10641b59eebc8bed30.zip
dev-ruby/fiber-local: new package, add 1.0.0
Signed-off-by: matoro <matoro@users.noreply.github.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-ruby/fiber-local')
-rw-r--r--dev-ruby/fiber-local/Manifest1
-rw-r--r--dev-ruby/fiber-local/fiber-local-1.0.0.ebuild25
-rw-r--r--dev-ruby/fiber-local/metadata.xml11
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/fiber-local/Manifest b/dev-ruby/fiber-local/Manifest
new file mode 100644
index 000000000000..52c6faa57383
--- /dev/null
+++ b/dev-ruby/fiber-local/Manifest
@@ -0,0 +1 @@
+DIST fiber-local-1.0.0.tar.gz 3780 BLAKE2B 5360ebdc2f3958863742e5ca1e1cdefe76e4487bad2257a1bd34a8a6769b1191e1a8f0ba8c7dfe1481f73fdd8b9ee1a014b11e5527273dbb0ee6d8a94edae2ae SHA512 5f77213c3760bb7c23a6912f138e46aa54d8508c11d02dadde5ddbc4ab03976abccb37ad2b1b43b118eddfb7a5e8ca4ee647a7fea1bac5ee4d7b39e8dc8f8424
diff --git a/dev-ruby/fiber-local/fiber-local-1.0.0.ebuild b/dev-ruby/fiber-local/fiber-local-1.0.0.ebuild
new file mode 100644
index 000000000000..ad2959e09769
--- /dev/null
+++ b/dev-ruby/fiber-local/fiber-local-1.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+inherit ruby-fakegem
+
+DESCRIPTION="Provides a class-level mixin to make fiber local state easy"
+HOMEPAGE="https://github.com/socketry/fiber-local"
+SRC_URI="https://github.com/socketry/fiber-local/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~sparc"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -E 's/require_relative "(.+)"/require File.expand_path("\1")/g' "${RUBY_FAKEGEM_GEMSPEC}" || die
+ rm -f "gems.rb" || die
+ sed -i -E 's/require '"'"'covered\/rspec'"'"'//g' "spec/spec_helper.rb" || die
+}
diff --git a/dev-ruby/fiber-local/metadata.xml b/dev-ruby/fiber-local/metadata.xml
new file mode 100644
index 000000000000..cbcf3060e8d9
--- /dev/null
+++ b/dev-ruby/fiber-local/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">socketry/fiber-local</remote-id>
+ </upstream>
+</pkgmetadata>