summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/coffee-rails
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/coffee-rails')
-rw-r--r--dev-ruby/coffee-rails/Manifest3
-rw-r--r--dev-ruby/coffee-rails/coffee-rails-3.2.2.ebuild35
-rw-r--r--dev-ruby/coffee-rails/coffee-rails-4.0.1.ebuild31
-rw-r--r--dev-ruby/coffee-rails/coffee-rails-4.1.0.ebuild32
-rw-r--r--dev-ruby/coffee-rails/metadata.xml8
5 files changed, 109 insertions, 0 deletions
diff --git a/dev-ruby/coffee-rails/Manifest b/dev-ruby/coffee-rails/Manifest
new file mode 100644
index 000000000000..0430cad06f96
--- /dev/null
+++ b/dev-ruby/coffee-rails/Manifest
@@ -0,0 +1,3 @@
+DIST coffee-rails-3.2.2.gem 7168 SHA256 75f06d71060999044fbc6ac199b91f1fc0bd075d8dd8acde04e02431396b463a SHA512 b4c6a6d0658f50fcd7632260bbddb25e619a9dfb45c0bab8fd60cbfaf32480875fc4b90bd0e77eef5cf25b84b1de08b1bf335454b2c828340ea20a0986373244 WHIRLPOOL 629fde6c30f1288146284dff0b53e2cc6f5469a8c51a625628435b88bf7e9087352da1a7bf5711b4496c92084272aebfa254ddd41b009157646f062738cc3d95
+DIST coffee-rails-4.0.1.gem 9216 SHA256 2f6e36f2c7a2b5ea4ba2aae5d8f70b443e47f010e1f645aec28368d783e1d88a SHA512 33a4efc0350977ede05e869ceed0cc5c9902d2f75ade6c84fada2d1265323af4798ffe0f0994d0d7b4a7bbb7e48c7360e04c729bc117c7d4448c986f238fdbae WHIRLPOOL c1a5b1890648df1229d474cc9e33dbfcc339971ea6ca3b3cf584fd055b4ce1bb2a6cf33119499aab1715f6b5b2ddd7855467da2b31e718edab480644f045f7bb
+DIST coffee-rails-4.1.0.gem 9216 SHA256 1adbc3d1e3e4d835643e7848b3279a7a1deadd8711be6a41bac1eb4788867f5c SHA512 b3aeaa0d54646cc3ac0b0c6987411b6deb1ed3a432e8cbe489f5be9b1d4558332afba561ff9844b2a74bf09665df063b2d4a08d85bb32c82b7ec8c14a2391fa0 WHIRLPOOL d1ca71933d3e3f9ab2a04ff2197725f6ea2a9f7079897f9e29c85f6094322234db4f844e1e814d5c858f04d6cf3dea6169069be6a5f16ce0611ce48e31dcd4da
diff --git a/dev-ruby/coffee-rails/coffee-rails-3.2.2.ebuild b/dev-ruby/coffee-rails/coffee-rails-3.2.2.ebuild
new file mode 100644
index 000000000000..d6767b18e4a7
--- /dev/null
+++ b/dev-ruby/coffee-rails/coffee-rails-3.2.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Coffee Script adapter for the Rails asset pipeline"
+HOMEPAGE="https://github.com/rails/coffee-rails"
+
+LICENSE="MIT"
+SLOT="3.2"
+KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
+
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/coffee-script-2.2.0
+ dev-ruby/railties:3.2"
+
+ruby_add_bdepend "test? ( dev-ruby/rails:3.2 )"
+
+all_ruby_prepare() {
+ sed -e '/git ls-files/d' -i coffee-rails.gemspec || die
+
+ # Make sure Rails 3.2 is used.
+ sed -e '4igem "rails", "~> 3.2.0"' -i test/test_helper.rb || die
+
+ # Apply upstream fix for failing test
+ sed -i -e 's/this.CoffeeScript/CoffeeScript Compiler/' test/assets_test.rb || die
+}
diff --git a/dev-ruby/coffee-rails/coffee-rails-4.0.1.ebuild b/dev-ruby/coffee-rails/coffee-rails-4.0.1.ebuild
new file mode 100644
index 000000000000..3d5183627028
--- /dev/null
+++ b/dev-ruby/coffee-rails/coffee-rails-4.0.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Coffee Script adapter for the Rails asset pipeline"
+HOMEPAGE="https://github.com/rails/coffee-rails"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~x86"
+
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/coffee-script-2.2.0
+ =dev-ruby/railties-4*"
+
+all_ruby_prepare() {
+ # Avoid dependency on git.
+ sed -i -e 's/git ls-files/echo/' Rakefile || die
+
+ # Make sure a consistent rails version is loaded.
+ sed -i -e '4igem "rails"' -e '/bundler/ s:^:#:' test/test_helper.rb || die
+}
diff --git a/dev-ruby/coffee-rails/coffee-rails-4.1.0.ebuild b/dev-ruby/coffee-rails/coffee-rails-4.1.0.ebuild
new file mode 100644
index 000000000000..10faf08a3b36
--- /dev/null
+++ b/dev-ruby/coffee-rails/coffee-rails-4.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Coffee Script adapter for the Rails asset pipeline"
+HOMEPAGE="https://github.com/rails/coffee-rails"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~x86"
+
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/coffee-script-2.2.0
+ =dev-ruby/railties-4*"
+
+all_ruby_prepare() {
+ # Avoid dependency on git and bundler.
+ sed -i -e 's/git ls-files/echo/' \
+ -e '/bundler/I s:^:#:' Rakefile || die
+
+ # Make sure a consistent rails version is loaded.
+ sed -i -e '4igem "rails"' -e '/bundler/ s:^:#:' test/test_helper.rb || die
+}
diff --git a/dev-ruby/coffee-rails/metadata.xml b/dev-ruby/coffee-rails/metadata.xml
new file mode 100644
index 000000000000..f312fb9d28cc
--- /dev/null
+++ b/dev-ruby/coffee-rails/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">rails/coffee-rails</remote-id>
+ </upstream>
+</pkgmetadata>