summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-09-10 08:45:52 +0200
committerHans de Graaff <graaff@gentoo.org>2023-09-10 08:48:02 +0200
commit1ac606eb0f7c609e251adb915dda2605204badf8 (patch)
tree5d0779f85d3ae021155a9c4d05bac68068093b82 /dev-ruby/actionpack
parentdev-ruby/actionview: add 7.0.8 (diff)
downloadgentoo-1ac606eb0f7c609e251adb915dda2605204badf8.tar.gz
gentoo-1ac606eb0f7c609e251adb915dda2605204badf8.tar.bz2
gentoo-1ac606eb0f7c609e251adb915dda2605204badf8.zip
dev-ruby/actionpack: add 7.0.8
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/actionpack')
-rw-r--r--dev-ruby/actionpack/Manifest1
-rw-r--r--dev-ruby/actionpack/actionpack-7.0.8.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-ruby/actionpack/Manifest b/dev-ruby/actionpack/Manifest
index d5b69a9875cb..655ecd754075 100644
--- a/dev-ruby/actionpack/Manifest
+++ b/dev-ruby/actionpack/Manifest
@@ -2,3 +2,4 @@ DIST rails-6.1.7.4.tgz 11038583 BLAKE2B 737044b6f92f2555fd9374e0b0fef7e26e53e2ac
DIST rails-6.1.7.6.tgz 11040086 BLAKE2B 8b5311752952403cf8eae31b5d8e8d376c4b449f512e86df66b3e921375ffa3ea11e15f1d74a7f8ec9179ff70c32a6d4f8de75be5f92fe6315ee97164e22d2d0 SHA512 c4163565b2324ce97317d252f3d9e2e673a12b6ae7f54571645c958ce30221f1b357887ade80e46abdd47a422736b9946e49850d52ffd72d8acc87f35224e69f
DIST rails-7.0.7.2.tgz 11085454 BLAKE2B 05574b6df7e28e409949fb311110fd7137d61c31072b394f950a180135201132f3cf9c5cca8f76c661827d7a5e807bfc4b0c97a449b8941115cbe3a0f2f84f62 SHA512 41fad11bd272ea21f7d15d855da04230f0801d9926f6ce3300754f1b2b9d691f18e55855b1a71e44faaf483b397b02ac11c75eb415b7c8976868bc9aefe5b005
DIST rails-7.0.7.tgz 11071730 BLAKE2B 215642609be86bd9977dc2cdb09a76c64e99260359d0a60aa411a5df572d7699a5f9959ea8aa0ff116ad75110db060436abcfb17da689b1a6aa819fd56373279 SHA512 75f952dfe4d9abc1473dfb017e42daec6358a45efad14a3b39a1b2dc5fec566757c2225fe920a4e872e896966cfb1d4b6e1c40c93d2043aec3bf5bd25ff7c956
+DIST rails-7.0.8.tgz 11073254 BLAKE2B 2aee047a365acb0890ef3afbccfe323fedccf7b54214aa1c2f92b7a7aaa64c275c1e03f8f97e6a2e30281224ba30703d18b40aeee9b4e7fb6f035a4a7716a054 SHA512 0e9feb5bd0360868c3109152d8ea414b65d36d33a5dbb96b199cfa6c4335800d6c392e0fbcbfa453a02fd75924a297a65caf04948895de53db43700478dbeb11
diff --git a/dev-ruby/actionpack/actionpack-7.0.8.ebuild b/dev-ruby/actionpack/actionpack-7.0.8.ebuild
new file mode 100644
index 000000000000..3deadbaecbba
--- /dev/null
+++ b/dev-ruby/actionpack/actionpack-7.0.8.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionpack.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Eases web-request routing, handling, and response"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ ~dev-ruby/actionview-${PV}
+ dev-ruby/rack:2.2
+ >=dev-ruby/rack-test-0.6.3:*
+ >=dev-ruby/rails-html-sanitizer-1.2.0:1
+ dev-ruby/rails-dom-testing:2
+"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/mocha:0.14
+ dev-ruby/bundler
+ >=dev-ruby/capybara-3.26
+ ~dev-ruby/activemodel-${PV}
+ ~dev-ruby/railties-${PV}
+ >=dev-ruby/rack-cache-1.2:1.2
+ dev-ruby/selenium-webdriver:4
+ www-servers/puma
+ <dev-ruby/minitest-5.16:*
+ )"
+
+all_ruby_prepare() {
+ eapply "${FILESDIR}/actionpack-7.0.4-rack-test-2.patch"
+
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|sprockets\|stackprof\)/ s:^:#:" \
+ -e '/:job/,/end/ s:^:#:' \
+ -e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
+ rm ../Gemfile.lock || die
+
+ sed -i -e '3igem "rack", "<3"; gem "minitest", "<5.16"' test/abstract_unit.rb || die
+
+ # Use different timezone notation, this changed at some point due to an external dependency changing.
+ sed -e 's/-0000/GMT/' \
+ -i test/dispatch/response_test.rb test/dispatch/cookies_test.rb test/dispatch/session/cookie_store_test.rb || die
+
+ # Avoid tests that fail with a fixed cgi.rb version
+ sed -e '/test_session_store_with_all_domains/askip "Fails with fixed cgi.rb"' \
+ -i test/dispatch/session/cookie_store_test.rb || die
+}