summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-03-15 08:32:03 +0100
committerHans de Graaff <graaff@gentoo.org>2023-03-15 08:33:12 +0100
commit650de9e2053db6ac67e78b99fd25e1eb78391f31 (patch)
treef4424cd9c9315d7bb453ff9122375d800f2d3123 /dev-ruby/actionmailer/actionmailer-7.0.4.3.ebuild
parentdev-ruby/activestorage: add 7.0.4.3 (diff)
downloadgentoo-650de9e2053db6ac67e78b99fd25e1eb78391f31.tar.gz
gentoo-650de9e2053db6ac67e78b99fd25e1eb78391f31.tar.bz2
gentoo-650de9e2053db6ac67e78b99fd25e1eb78391f31.zip
dev-ruby/actionmailer: add 7.0.4.3
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/actionmailer/actionmailer-7.0.4.3.ebuild')
-rw-r--r--dev-ruby/actionmailer/actionmailer-7.0.4.3.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-ruby/actionmailer/actionmailer-7.0.4.3.ebuild b/dev-ruby/actionmailer/actionmailer-7.0.4.3.ebuild
new file mode 100644
index 000000000000..e287b380286b
--- /dev/null
+++ b/dev-ruby/actionmailer/actionmailer-7.0.4.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionmailer.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/actionview-${PV}
+ ~dev-ruby/activejob-${PV}
+ >=dev-ruby/mail-2.5.4:* =dev-ruby/mail-2*:*
+ dev-ruby/rails-dom-testing:2"
+
+ruby_add_bdepend "test? (
+ dev-ruby/mocha
+)"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/\/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+ # Avoid a test failing only on attachment ordering, since this is a
+ # security release.
+ sed -i -e '/adding inline attachments while rendering mail works/askip "gentoo: fails on ordering"' test/base_test.rb || die
+}