summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-10-14 12:47:27 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-10-14 13:05:04 +0200
commitff1499e66697210788ca5b4a7b0f7f868fbc8d07 (patch)
treec014b53eaa4c7a74f555967e794afb7179b95135 /dev-ros
parentdev-ros/libmavconn: Bump to 1.4.0. (diff)
downloadgentoo-ff1499e66697210788ca5b4a7b0f7f868fbc8d07.tar.gz
gentoo-ff1499e66697210788ca5b4a7b0f7f868fbc8d07.tar.bz2
gentoo-ff1499e66697210788ca5b4a7b0f7f868fbc8d07.zip
dev-ros/mavros: Bump to 1.4.0.
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/mavros/Manifest1
-rw-r--r--dev-ros/mavros/mavros-1.4.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-ros/mavros/Manifest b/dev-ros/mavros/Manifest
index 66ac5ab4477a..a4cbf1623ad5 100644
--- a/dev-ros/mavros/Manifest
+++ b/dev-ros/mavros/Manifest
@@ -1 +1,2 @@
DIST mavros-1.2.0.tar.gz 309704 BLAKE2B 85fa9079e6e26a5507878a092f671dfc387f52c65b9d1b2ba1f66d98439369550807b8afe3c99e276725b0c14d479eb1df2bd75870f2b78fe6e95c6020355cc9 SHA512 b37e3713ab15bdac23e88f3e7111821c7eaaaa263d7354852a18dd1e9f6f782a2e9450b29264536b8d712ab04021ddd84d82deeb932715d8e486dc019bb6f374
+DIST mavros-1.4.0.tar.gz 316881 BLAKE2B 2f7d401024fb8ce08a91e70b175bfacfcd6ec28ae8bd744ed4fba20c8a8362eaed71143c3fa34b53084d92ed5bccda3b291bc08f310f7a1c48fb25f608709c48 SHA512 d09c328d9878ada83c2c34cd44b582085e2ca5770ce78b6a52d27545333d43d5f7f92be14e3636db5ecee8d8d9e95134693ec8d4676adee5e1307ac958f182b6
diff --git a/dev-ros/mavros/mavros-1.4.0.ebuild b/dev-ros/mavros/mavros-1.4.0.ebuild
new file mode 100644
index 000000000000..74118adcd502
--- /dev/null
+++ b/dev-ros/mavros/mavros-1.4.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/mavlink/mavros"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="MAVLink extendable communication node for ROS"
+LICENSE="GPL-3 LGPL-3 BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_updater
+ dev-ros/pluginlib
+ dev-libs/tinyxml2:=
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/angles
+ dev-ros/libmavconn
+ dev-ros/rosconsole_bridge
+ dev-libs/boost:=
+ dev-ros/eigen_conversions
+ sci-geosciences/GeographicLib
+ >=dev-ros/mavlink-gbp-release-2016.11.11
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ >=dev-ros/mavros_msgs-${PV}[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"