summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-05-13 12:48:46 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-05-13 12:48:59 +0200
commitc71f7eb0abb685c1bdf5d1816bae8db36a7d0a97 (patch)
tree5ab8f60a566bbd9faf7e04698549cd79f71b6174 /dev-ros
parentdev-ros/pluginlib: Remove old (diff)
downloadgentoo-c71f7eb0abb685c1bdf5d1816bae8db36a7d0a97.tar.gz
gentoo-c71f7eb0abb685c1bdf5d1816bae8db36a7d0a97.tar.bz2
gentoo-c71f7eb0abb685c1bdf5d1816bae8db36a7d0a97.zip
dev-ros/pluginlib: bump to 1.12.1
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/pluginlib/Manifest1
-rw-r--r--dev-ros/pluginlib/pluginlib-1.12.1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/pluginlib/Manifest b/dev-ros/pluginlib/Manifest
index 11fa625078d6..3d7ee7a419eb 100644
--- a/dev-ros/pluginlib/Manifest
+++ b/dev-ros/pluginlib/Manifest
@@ -1 +1,2 @@
DIST pluginlib-1.12.0.tar.gz 20298 BLAKE2B 9d6e5adb6bd64f02d237fa1992402cb016266071c0fa0447709880f90550f36f9e280163a3e054594235d0102f7fb22f4b98a56216b0db9ebaa200b99d018570 SHA512 fcd51908c6c7223bbe50eb43733ba6d00e11419b26d2b9a05aaaf6498020fcd44bacc19313c3a4dd7524bf69d4f54aec27e05b1f88ee578191484c53c1e3f767
+DIST pluginlib-1.12.1.tar.gz 19619 BLAKE2B e91fb15b4857fae10012a71df606f5040d5a62bdee596695c873808790eea02cd380eedda6c438388264003d7ac930ebc2c649a421411580dd095365c93d3c8e SHA512 1a15cd934c4f93fecf32d7d3cab1ee6caae61d59aa65d1f796ab2ba63d5204a6fe28744c28eac80d304bd802b184afe79ead621b3c370c6d3526a944c144d724
diff --git a/dev-ros/pluginlib/pluginlib-1.12.1.ebuild b/dev-ros/pluginlib/pluginlib-1.12.1.ebuild
new file mode 100644
index 000000000000..5346810670b3
--- /dev/null
+++ b/dev-ros/pluginlib/pluginlib-1.12.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/pluginlib"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+ROS_SUBDIR="${PN}"
+
+inherit ros-catkin
+
+DESCRIPTION="Provides tools for writing and dynamically loading plugins using the ROS build infrastructure"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-ros/class_loader-0.3.5:=
+ dev-ros/rosconsole
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-libs/boost:=
+ dev-libs/tinyxml2:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"
+PATCHES=( "${FILESDIR}/catkin_prefix_path2.patch" )