summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-10-20 14:56:27 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-10-20 15:30:39 +0200
commit5325b818fcbbfa69167e32735281dcf5a0cffbb1 (patch)
tree505e002615d431231543b288205582e143794e1d /dev-ros
parentdev-ros/pcl_ros: bump to 1.7.2 (diff)
downloadgentoo-5325b818fcbbfa69167e32735281dcf5a0cffbb1.tar.gz
gentoo-5325b818fcbbfa69167e32735281dcf5a0cffbb1.tar.bz2
gentoo-5325b818fcbbfa69167e32735281dcf5a0cffbb1.zip
dev-ros/rosconsole: bump to 1.14.3
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/rosconsole/Manifest1
-rw-r--r--dev-ros/rosconsole/rosconsole-1.14.3.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-ros/rosconsole/Manifest b/dev-ros/rosconsole/Manifest
index b5f9fd638b57..0b2986898f0c 100644
--- a/dev-ros/rosconsole/Manifest
+++ b/dev-ros/rosconsole/Manifest
@@ -1,2 +1,3 @@
DIST rosconsole-1.14.0.tar.gz 26166 BLAKE2B 79d73e5918eb5f3837e57e4207b3b42cc3222a92e8357265132d2d0848f966fa1e1aed69f8809af30497ef6b1f52c0de0073c20bf6e309010a8d98e0f745fb9c SHA512 68a5d709294b162d5b424bdbcd70fb66a43ccd8512bc60f571fe24bb0150e52f93addc3f22777c2f5810e95492265be58d3cfc6563a4e66665b3261ef161d5cd
DIST rosconsole-1.14.2.tar.gz 26212 BLAKE2B b43f07f920a526c740d1ee8c3f5d7f5724ed617adad409df84001571e0df30df65c200bfc50c4c6a97a24642b3ad61340706ed4b6d14822935256bfb305350a3 SHA512 f1af112ada723195acda17edb64f75969a0abea58504d14507470eb36b0649e028cd675a368e040ddc955216da304dd64416fda8de7bc29dcd73c56c8286f311
+DIST rosconsole-1.14.3.tar.gz 26274 BLAKE2B 77547855d29bd837144663cff15ef0d5711ffbabacad161de0903df7acdda45bf2461718ce78ee1c9706a455ff1398876ed2014382bc4f39f08174cffc6ebae9 SHA512 a134dea50a8fb5cef600eecdf2e7402d7c95da364081f9619ae4a75be8782b28acdd4535146da2493b2e533867e7d7968398e83ea6d5438c171168ffab30ea97
diff --git a/dev-ros/rosconsole/rosconsole-1.14.3.ebuild b/dev-ros/rosconsole/rosconsole-1.14.3.ebuild
new file mode 100644
index 000000000000..76c9a71eb9d4
--- /dev/null
+++ b/dev-ros/rosconsole/rosconsole-1.14.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/rosconsole"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="ROS console output library"
+LICENSE="BSD"
+SLOT="0"
+IUSE="+log4cxx glog"
+
+RDEPEND="
+ dev-ros/cpp_common
+ dev-ros/rostime
+ dev-ros/rosunit
+ dev-libs/boost:=[threads]
+ log4cxx? ( dev-libs/log4cxx )
+ !log4cxx? ( glog? ( dev-cpp/glog ) )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local ROSCONSOLE_BACKEND=""
+ if use log4cxx; then
+ ROSCONSOLE_BACKEND="log4cxx"
+ elif use glog; then
+ ROSCONSOLE_BACKEND="glog"
+ else
+ ROSCONSOLE_BACKEND="print"
+ fi
+ local mycatkincmakeargs=( "-DROSCONSOLE_BACKEND=${ROSCONSOLE_BACKEND}" )
+ ros-catkin_src_configure
+}