summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 16:32:57 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 16:36:31 +0200
commit5bc0f5a5aca371027e946648524e14b30700e059 (patch)
treeaf2f93d67c00a2ca945e805ed041f9846f3c5b98 /dev-ros/test_rosmaster/test_rosmaster-9999.ebuild
parentdev-ros/test_rospy: Initial import. Ebuild by me. (diff)
downloadgentoo-5bc0f5a5aca371027e946648524e14b30700e059.tar.gz
gentoo-5bc0f5a5aca371027e946648524e14b30700e059.tar.bz2
gentoo-5bc0f5a5aca371027e946648524e14b30700e059.zip
dev-ros/test_rosmaster: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/test_rosmaster/test_rosmaster-9999.ebuild')
-rw-r--r--dev-ros/test_rosmaster/test_rosmaster-9999.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ros/test_rosmaster/test_rosmaster-9999.ebuild b/dev-ros/test_rosmaster/test_rosmaster-9999.ebuild
new file mode 100644
index 000000000000..d07a5558dbe9
--- /dev/null
+++ b/dev-ros/test_rosmaster/test_rosmaster-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rosmaster"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/std_msgs[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/roslib[${PYTHON_USEDEP}] )
+"
+
+src_install() {
+ ros-catkin_src_install
+ dodir /usr/share/${PN}
+ cp -a test "${ED}//usr/share/${PN}/" || die
+}