summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2023-01-24 18:08:15 +0100
committerJakov Smolić <jsmolic@gentoo.org>2023-01-24 21:16:20 +0100
commit4b593b08caf04c84dcc67d35b1f00723e015ce01 (patch)
tree6df232218b50191350595b5803ddf2409820651a /dev-ros/test_roscpp/test_roscpp-9999.ebuild
parentdev-ros/test_rosbag_storage: treeclean (diff)
downloadgentoo-4b593b08caf04c84dcc67d35b1f00723e015ce01.tar.gz
gentoo-4b593b08caf04c84dcc67d35b1f00723e015ce01.tar.bz2
gentoo-4b593b08caf04c84dcc67d35b1f00723e015ce01.zip
dev-ros/test_roscpp: treeclean
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'dev-ros/test_roscpp/test_roscpp-9999.ebuild')
-rw-r--r--dev-ros/test_roscpp/test_roscpp-9999.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-ros/test_roscpp/test_roscpp-9999.ebuild b/dev-ros/test_roscpp/test_roscpp-9999.ebuild
deleted file mode 100644
index f361fe9e6e25..000000000000
--- a/dev-ros/test_roscpp/test_roscpp-9999.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-ROS_REPO_URI="https://github.com/ros/ros_comm"
-KEYWORDS="~amd64 ~arm"
-ROS_SUBDIR=test/${PN}
-CATKIN_HAS_MESSAGES=yes
-CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/rosgraph_msgs dev-ros/std_msgs"
-
-inherit ros-catkin
-
-DESCRIPTION="Unit tests for roscpp"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- dev-ros/roscpp
- dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
- dev-ros/rosunit[${PYTHON_SINGLE_USEDEP}]
- dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-libs/boost:=
- test? (
- dev-cpp/gtest
- )
-"
-REQUIRED_USE="test? ( ros_messages_cxx )"
-PATCHES=( "${FILESDIR}/tests.patch" )
-
-src_test() {
- export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
- # Sometimes high number of tests running in parallel make them fail
- # https://bugs.gentoo.org/738620
- ros-catkin_src_test -j 1
-}