summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-08-07 17:04:19 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-08-07 17:32:47 +0200
commitaeaad470b10a05ad22bcd210b75704d37e55634e (patch)
treec2a2a7d40d36220e3e49e2dbab0977435756f4e8 /dev-ros/rostopic
parentdev-ros/rostopic: Remove old (diff)
downloadgentoo-aeaad470b10a05ad22bcd210b75704d37e55634e.tar.gz
gentoo-aeaad470b10a05ad22bcd210b75704d37e55634e.tar.bz2
gentoo-aeaad470b10a05ad22bcd210b75704d37e55634e.zip
dev-ros/rostopic: fix tests
Closes: https://bugs.gentoo.org/624792 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rostopic')
-rw-r--r--dev-ros/rostopic/rostopic-1.15.8.ebuild5
-rw-r--r--dev-ros/rostopic/rostopic-9999.ebuild5
2 files changed, 10 insertions, 0 deletions
diff --git a/dev-ros/rostopic/rostopic-1.15.8.ebuild b/dev-ros/rostopic/rostopic-1.15.8.ebuild
index 6482c6da1be0..c436e4f953a2 100644
--- a/dev-ros/rostopic/rostopic-1.15.8.ebuild
+++ b/dev-ros/rostopic/rostopic-1.15.8.ebuild
@@ -24,3 +24,8 @@ DEPEND="${RDEPEND}
$(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
)
"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}
diff --git a/dev-ros/rostopic/rostopic-9999.ebuild b/dev-ros/rostopic/rostopic-9999.ebuild
index 6482c6da1be0..c436e4f953a2 100644
--- a/dev-ros/rostopic/rostopic-9999.ebuild
+++ b/dev-ros/rostopic/rostopic-9999.ebuild
@@ -24,3 +24,8 @@ DEPEND="${RDEPEND}
$(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
)
"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}