summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-09 12:48:11 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-09 13:45:18 +0200
commit1bfeb7d5d9bfafd60171b8cbd10fd22daf0c17d8 (patch)
tree464af0378e4f948e8dd46bad17fd66985c374b9c /dev-ros/nodelet
parentmedia-radio/wsjtx: Bugfix release (diff)
downloadgentoo-1bfeb7d5d9bfafd60171b8cbd10fd22daf0c17d8.tar.gz
gentoo-1bfeb7d5d9bfafd60171b8cbd10fd22daf0c17d8.tar.bz2
gentoo-1bfeb7d5d9bfafd60171b8cbd10fd22daf0c17d8.zip
dev-ros/nodelet: Bump to 1.10.0.
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/nodelet')
-rw-r--r--dev-ros/nodelet/Manifest1
-rw-r--r--dev-ros/nodelet/nodelet-1.10.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ros/nodelet/Manifest b/dev-ros/nodelet/Manifest
index f20f055d6cd9..3a6be1550d0a 100644
--- a/dev-ros/nodelet/Manifest
+++ b/dev-ros/nodelet/Manifest
@@ -1 +1,2 @@
+DIST nodelet_core-1.10.0.tar.gz 45386 BLAKE2B 1da08ec8bc134e0eba72d7c0cde7cfd351c91c5bf4bc8d66ad3d30a8dbe39452c511b6a753ea91a139ce06b617d71f06cfb2f67c7ee2482eb5d2aba79680799c SHA512 4a298cc214660050b7a4d4f3a1e8980cbde2d05bb19369856031a128d3ca7518cbbd4615fe8c0c5944b09dca96aeaa8f41a630b2f34f9e2af423349e816c54e9
DIST nodelet_core-1.9.16.tar.gz 44194 BLAKE2B e174ae42d7a6e91f20dee25c8740f0c339b660040d11e2231a350b1f0ca4f37ab48e1811f0aa66a8365f3c280e4ba923aa7f0a2e0997400b2b8ea1775d6fa780 SHA512 36408735028e6034f551e331da8379f5d9dd37128f749830cd5654298fc02c3fdc609e82cdb314cefcb06bd6d36eb6b37f6efa468487ee8068a4da6d0b8c1787
diff --git a/dev-ros/nodelet/nodelet-1.10.0.ebuild b/dev-ros/nodelet/nodelet-1.10.0.ebuild
new file mode 100644
index 000000000000..be2fa68eb177
--- /dev/null
+++ b/dev-ros/nodelet/nodelet-1.10.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/nodelet_core"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+PYTHON_COMPAT=( python{2_7,3_6} pypy3 )
+
+inherit ros-catkin
+
+DESCRIPTION="Provides a way to run multiple algorithms in the same process with zero copy transport"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/bondcpp
+ dev-ros/cmake_modules
+ dev-ros/pluginlib
+ dev-libs/tinyxml2:=
+ dev-ros/rosconsole
+ dev-libs/console_bridge:=
+ dev-ros/roscpp
+ dev-libs/boost:=
+ sys-apps/util-linux
+ dev-ros/class_loader:=
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"