summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-09 13:13:28 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-09 13:45:29 +0200
commit2ac1e8fef5a8d86f6df860a106986e29a2e70a6f (patch)
tree5f5402fac11c54882fef5e0b6b81797f8d430f79 /dev-ros/image_rotate/image_rotate-1.15.2.ebuild
parentdev-ros/image_publisher: Bump to 1.15.2. (diff)
downloadgentoo-2ac1e8fef5a8d86f6df860a106986e29a2e70a6f.tar.gz
gentoo-2ac1e8fef5a8d86f6df860a106986e29a2e70a6f.tar.bz2
gentoo-2ac1e8fef5a8d86f6df860a106986e29a2e70a6f.zip
dev-ros/image_rotate: Bump to 1.15.2.
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/image_rotate/image_rotate-1.15.2.ebuild')
-rw-r--r--dev-ros/image_rotate/image_rotate-1.15.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/image_rotate/image_rotate-1.15.2.ebuild b/dev-ros/image_rotate/image_rotate-1.15.2.ebuild
new file mode 100644
index 000000000000..9d1bc4e6d83b
--- /dev/null
+++ b/dev-ros/image_rotate/image_rotate-1.15.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Rotates an image stream minimizing the angle between an arbitrary vector and the camera frame"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ media-libs/opencv:=
+ dev-ros/dynamic_reconfigure
+ dev-ros/eigen_conversions
+ dev-ros/image_transport
+ dev-ros/nodelet
+ dev-libs/console_bridge:=
+ dev-ros/roscpp
+ dev-ros/tf2
+ dev-ros/tf2_geometry_msgs
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}"