summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-13 07:07:53 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-04-13 08:35:10 +0300
commite5cacb67a9e256438731422e14384c16dd0a3897 (patch)
tree2d892fd30db6ab926a2a9fe0c931622fb0711407 /dev-python
parentdev-python/xkbcommon: Bump to 1.0 (diff)
downloadgentoo-e5cacb67a9e256438731422e14384c16dd0a3897.tar.gz
gentoo-e5cacb67a9e256438731422e14384c16dd0a3897.tar.bz2
gentoo-e5cacb67a9e256438731422e14384c16dd0a3897.zip
dev-python/aiohttp-cors: Fix errors with pytest-8
Closes: https://bugs.gentoo.org/928354 Signed-off-by: Michał Górny <mgorny@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/36231 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/aiohttp-cors/aiohttp-cors-0.7.0-r2.ebuild23
1 files changed, 15 insertions, 8 deletions
diff --git a/dev-python/aiohttp-cors/aiohttp-cors-0.7.0-r2.ebuild b/dev-python/aiohttp-cors/aiohttp-cors-0.7.0-r2.ebuild
index b9f9a8493b93..3b66370dac42 100644
--- a/dev-python/aiohttp-cors/aiohttp-cors-0.7.0-r2.ebuild
+++ b/dev-python/aiohttp-cors/aiohttp-cors-0.7.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -34,13 +34,20 @@ BDEPEND="
distutils_enable_tests pytest
-PATCHES=(
- # https://github.com/aio-libs/aiohttp-cors/pull/278
- "${FILESDIR}/${P}-tests.patch"
- "${FILESDIR}/${P}-py3_7.patch"
- # https://github.com/aio-libs/aiohttp-cors/pull/412
- "${FILESDIR}/${P}-py3_11.patch"
-)
+src_prepare() {
+ local PATCHES=(
+ # https://github.com/aio-libs/aiohttp-cors/pull/278
+ "${FILESDIR}/${P}-tests.patch"
+ "${FILESDIR}/${P}-py3_7.patch"
+ # https://github.com/aio-libs/aiohttp-cors/pull/412
+ "${FILESDIR}/${P}-py3_11.patch"
+ )
+
+ # doesn't do anything, except for breaking pytest-8
+ rm conftest.py || die
+
+ distutils-r1_src_prepare
+}
python_test() {
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1