summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-04-24 19:20:47 +0200
committerMichał Górny <mgorny@gentoo.org>2017-04-25 23:49:12 +0200
commitd97c60b5c1273e8e6b9899d54522ef5dbdd3866b (patch)
tree61cd5f1868d1ab23482c531fcaa0cc7f7dd87246 /dev-python
parentdev-python/pypy: Update the distutils-cxx patch for upcoming 5.7.1 (diff)
downloadgentoo-d97c60b5c1273e8e6b9899d54522ef5dbdd3866b.tar.gz
gentoo-d97c60b5c1273e8e6b9899d54522ef5dbdd3866b.tar.bz2
gentoo-d97c60b5c1273e8e6b9899d54522ef5dbdd3866b.zip
dev-python/pypy: Bump 9999 to EAPI 6
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pypy/files/2.5.0-shared-lib.patch4
-rw-r--r--dev-python/pypy/pypy-9999.ebuild18
2 files changed, 11 insertions, 11 deletions
diff --git a/dev-python/pypy/files/2.5.0-shared-lib.patch b/dev-python/pypy/files/2.5.0-shared-lib.patch
index ddd74730f3dd..b5c877bd58b2 100644
--- a/dev-python/pypy/files/2.5.0-shared-lib.patch
+++ b/dev-python/pypy/files/2.5.0-shared-lib.patch
@@ -1,6 +1,6 @@
diff -ur pypy-2.5.0-src.orig/rpython/translator/platform/posix.py pypy-2.5.0-src/rpython/translator/platform/posix.py
---- rpython/translator/platform/posix.py 2015-02-03 05:12:49.000000000 +0800
-+++ rpython/translator/platform/posix.py 2015-03-22 07:36:01.420116684 +0800
+--- a/rpython/translator/platform/posix.py 2015-02-03 05:12:49.000000000 +0800
++++ b/rpython/translator/platform/posix.py 2015-03-22 07:36:01.420116684 +0800
@@ -183,7 +183,7 @@
'int main(int argc, char* argv[]) '
'{ return $(PYPY_MAIN_FUNCTION)(argc, argv); }" > $@')
diff --git a/dev-python/pypy/pypy-9999.ebuild b/dev-python/pypy/pypy-9999.ebuild
index c6a8bd089607..c4d67f9bbc16 100644
--- a/dev-python/pypy/pypy-9999.ebuild
+++ b/dev-python/pypy/pypy-9999.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
PYTHON_COMPAT=( python2_7 pypy )
EHG_REPO_URI="https://bitbucket.org/pypy/pypy"
-inherit check-reqs eutils mercurial multilib multiprocessing pax-utils python-any-r1 toolchain-funcs versionator
+inherit check-reqs mercurial multiprocessing pax-utils python-any-r1 toolchain-funcs versionator
# note: remember to update this to newest dev-lang/python:2.7 on bump
CPY_PATCHSET_VERSION="2.7.13-0"
@@ -93,9 +93,9 @@ src_unpack() {
}
src_prepare() {
- epatch "${FILESDIR}/4.0.0-gentoo-path.patch" \
- "${FILESDIR}/1.9-distutils.unixccompiler.UnixCCompiler.runtime_library_dir_option.patch" \
- "${FILESDIR}"/2.5.0-shared-lib.patch # 517002
+ eapply "${FILESDIR}/4.0.0-gentoo-path.patch"
+ eapply "${FILESDIR}/1.9-distutils.unixccompiler.UnixCCompiler.runtime_library_dir_option.patch"
+ eapply "${FILESDIR}"/2.5.0-shared-lib.patch # 517002
sed -e "s^@EPREFIX@^${EPREFIX}^" \
-e "s^@libdir@^$(get_libdir)^" \
@@ -105,11 +105,11 @@ src_prepare() {
pushd lib-python/2.7 > /dev/null || die
# TODO: cpy turkish locale patch now fixes C code
# probably needs better port to pypy, if it is broken there
- epatch "${FILESDIR}"/5.7.1_all_distutils_cxx.patch \
- "${WORKDIR}"/patches/62_all_xml.use_pyxml.patch
+ eapply "${FILESDIR}"/5.7.1_all_distutils_cxx.patch
+ eapply "${WORKDIR}"/patches/62_all_xml.use_pyxml.patch
popd > /dev/null || die
- epatch_user
+ eapply_user
}
src_configure() {
@@ -220,7 +220,7 @@ src_install() {
fi
# Install docs
- use doc && dohtml -r pypy/doc/_build/html/
+ use doc && dodoc -r pypy/doc/_build/html
einfo "Generating caches and byte-compiling ..."