summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-02-17 15:39:17 +0100
committerMichał Górny <mgorny@gentoo.org>2025-02-17 21:46:59 +0100
commitd68b0f0ad01fd91b191cf02ff1fd5411bffba157 (patch)
tree63ffc9ff5f1a1836296f202d485a7f33fee2ab19 /dev-python
parentdev-python/poetry: Bump to 2.1.1 (diff)
downloadgentoo-d68b0f0ad01fd91b191cf02ff1fd5411bffba157.tar.gz
gentoo-d68b0f0ad01fd91b191cf02ff1fd5411bffba157.tar.bz2
gentoo-d68b0f0ad01fd91b191cf02ff1fd5411bffba157.zip
dev-python/flake8: Bump to 7.1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/flake8/Manifest1
-rw-r--r--dev-python/flake8/flake8-7.1.2.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/flake8/Manifest b/dev-python/flake8/Manifest
index 520aaf1979ca..88d38f210a79 100644
--- a/dev-python/flake8/Manifest
+++ b/dev-python/flake8/Manifest
@@ -1 +1,2 @@
DIST flake8-7.1.1.gh.tar.gz 138915 BLAKE2B 5c00c4a95f0757f7d3716270ca1de91580cb1731c700227d563c08798981c124c5789f40a5965ad49450a77601ab9638d04cb32ef9c13418720c4123ba2a7932 SHA512 310457e3c701f746d812cc76664bcb79c7cbc320af9d757ebbc13c847f2c3864770d9b945694b4b6abb773ae636e19175222c3dab74d34559beaa7835f1d9931
+DIST flake8-7.1.2.gh.tar.gz 139099 BLAKE2B 4236a533cbaaa91c4c407af02890189ca65b7ebfe3af711df2cdba02e5a28963fc3622e0a0a41190168f3cd827ccb8fed4561cdcf352642f2660ec361657a43c SHA512 da90d07d45690efa433338ed6fcfaabdf08b5bf600783fa0f22b59f77bc560b81d3e0c8203c8fe92bd0b133f40fccd919d68c65cab9a266ea6f5bd45576b3837
diff --git a/dev-python/flake8/flake8-7.1.2.ebuild b/dev-python/flake8/flake8-7.1.2.ebuild
new file mode 100644
index 000000000000..25cbc7ee4d1c
--- /dev/null
+++ b/dev-python/flake8/flake8-7.1.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="A wrapper around PyFlakes, pep8 & mccabe"
+HOMEPAGE="
+ https://github.com/PyCQA/flake8/
+ https://pypi.org/project/flake8/
+"
+SRC_URI="
+ https://github.com/PyCQA/flake8/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ =dev-python/pyflakes-3.2*[${PYTHON_USEDEP}]
+ =dev-python/pycodestyle-2.12*[${PYTHON_USEDEP}]
+"
+PDEPEND="
+ =dev-python/mccabe-0.7*[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ ${PDEPEND}
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ dev-python/sphinx-prompt \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # fails if additional flake8 plugins are installed
+ tests/integration/test_plugins.py::test_local_plugin_can_add_option
+ )
+ if [[ ${EPYTHON} == pypy3 ]]; then
+ EPYTEST_DESELECT+=(
+ # problem with pypy3.10 in dev-python/pyflakes
+ # https://github.com/PyCQA/pyflakes/issues/779
+ tests/integration/test_main.py::test_malformed_per_file_ignores_error
+ tests/integration/test_main.py::test_tokenization_error_but_not_syntax_error
+ tests/integration/test_main.py::test_tokenization_error_is_a_syntax_error
+ )
+ fi
+
+ epytest
+}