summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-20 07:36:44 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-20 07:37:42 +0200
commitd37e2b77fac5ea8b7b2ddca4ca0ab1266c31e9ad (patch)
tree610f6586ccd58a42a38833352eaf0559ea3563e7 /dev-python
parentdev-python/hcloud-python: Remove old (diff)
downloadgentoo-d37e2b77fac5ea8b7b2ddca4ca0ab1266c31e9ad.tar.gz
gentoo-d37e2b77fac5ea8b7b2ddca4ca0ab1266c31e9ad.tar.bz2
gentoo-d37e2b77fac5ea8b7b2ddca4ca0ab1266c31e9ad.zip
dev-python/google-auth: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/google-auth/Manifest1
-rw-r--r--dev-python/google-auth/google-auth-2.10.0.ebuild58
2 files changed, 0 insertions, 59 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index fa703c2a6c23..9e61492a6b08 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -1,2 +1 @@
-DIST google-auth-2.10.0.tar.gz 205591 BLAKE2B e5b6ea1a65afc42318dc26ed5fa18de19232ca85e6da5be47c45b41861595f763b42bfdd92aaa63d20bbbf76fc1447dbeb7d88424ae5f82ce23ea9f875d04700 SHA512 91cf5391606b896691a9ae1489391bb0545c461172439c3011fc56c575f4a67341eb25a41faec437cb82fc0a2835adc95006327e3460591137238721a6eddd50
DIST google-auth-2.11.0.tar.gz 205568 BLAKE2B 76f43804c117006141e46291eaa35b49e73f4eec81307b7c3c6fdf82faf1a1f3101ef1a652c5dff05ca6686ded0859c6a3bee8d38cd584fd5cacef9598aae9b1 SHA512 0b2c8653184d95b1f0981326721a8604bee6737e2e4fb68c12d695c74e03406e6d189b00740c34ee74d6ae4032581bd099018f8eaf1d65759e4c5fa4127305cf
diff --git a/dev-python/google-auth/google-auth-2.10.0.ebuild b/dev-python/google-auth/google-auth-2.10.0.ebuild
deleted file mode 100644
index 37c2ffef06a9..000000000000
--- a/dev-python/google-auth/google-auth-2.10.0.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Google Authentication Library"
-HOMEPAGE="
- https://github.com/googleapis/google-auth-library-python/
- https://pypi.org/project/google-auth/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-
-RDEPEND="
- <dev-python/cachetools-6.0.0[${PYTHON_USEDEP}]
- >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
- >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
- >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- !dev-python/namespace-google
-"
-BDEPEND="
- test? (
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/grpcio[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/moto[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/pytest-localserver[${PYTHON_USEDEP}]
- dev-python/pyu2f[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/responses[${PYTHON_USEDEP}]
- dev-python/urllib3[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_IGNORE=(
- # these are compatibility tests with oauth2client
- # disable them to unblock removal of that package
- tests/test__oauth2client.py
-)
-
-python_compile() {
- distutils-r1_python_compile
- find "${BUILD_DIR}" -name '*.pth' -delete || die
-}