summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-12 05:28:56 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-12 05:35:21 +0200
commitbbd66e3a8fa94ed12205cdb3719c2206cb21cde5 (patch)
treed282ed47329434da8079d7dce18df29dc2fd9abc /dev-python
parentdev-python/kombu: Bump to 5.3.7 (diff)
downloadgentoo-bbd66e3a8fa94ed12205cdb3719c2206cb21cde5.tar.gz
gentoo-bbd66e3a8fa94ed12205cdb3719c2206cb21cde5.tar.bz2
gentoo-bbd66e3a8fa94ed12205cdb3719c2206cb21cde5.zip
dev-python/jsonpickle: Bump to 3.0.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jsonpickle/Manifest1
-rw-r--r--dev-python/jsonpickle/jsonpickle-3.0.4.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/jsonpickle/Manifest b/dev-python/jsonpickle/Manifest
index 39acf435721e..0379ee7ba86a 100644
--- a/dev-python/jsonpickle/Manifest
+++ b/dev-python/jsonpickle/Manifest
@@ -1 +1,2 @@
DIST jsonpickle-3.0.3.gh.tar.gz 259093 BLAKE2B a281f2054a4b7d66c746abecebb06326682e365941cfb880426bafc3aa0156202463a222a5c24a8eed89eb16ed90d01f38fa9728385e301c62ce27ee6abac770 SHA512 c3576c80d727f7b4f43e993a1dc68b0194dc4308cab9c7a9e3bd7e220a51fe2c2524c02d6afb5c1ead3c37c02d10c1106e89650fe6e609b5052f2a367150e8d1
+DIST jsonpickle-3.0.4.gh.tar.gz 260847 BLAKE2B ba990a59276463b66401cc9fdad2c91dfd18a172fa1cb2f0b89cbeb1a280360f6e1d5bf7cc3ec94069b1d05e4eb11d3fc52a594542f31ead220622aa01e0df99 SHA512 e6ad7ae30cc4d56323b612fcf599109828fcf76acfba266a1bed850a633603edc8829f29d8981659460a9941531d6735375a03775c9d7bd51c210edbf7414b1c
diff --git a/dev-python/jsonpickle/jsonpickle-3.0.4.ebuild b/dev-python/jsonpickle/jsonpickle-3.0.4.ebuild
new file mode 100644
index 000000000000..75bdde528e32
--- /dev/null
+++ b/dev-python/jsonpickle/jsonpickle-3.0.4.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for serializing any arbitrary object graph into JSON"
+HOMEPAGE="
+ https://github.com/jsonpickle/jsonpickle/
+ https://pypi.org/project/jsonpickle/
+"
+SRC_URI="
+ https://github.com/jsonpickle/jsonpickle/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/feedparser[${PYTHON_USEDEP}]
+ dev-python/gmpy[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/ujson[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -i -e 's:--cov::' pytest.ini || die
+ distutils-r1_python_prepare_all
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+}
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # unpackaged bson dependency
+ tests/bson_test.py
+ )
+
+ if ! has_version "dev-python/gmpy[${PYTHON_USEDEP}]"; then
+ EPYTEST_IGNORE+=( jsonpickle/ext/gmpy.py )
+ fi
+ if ! has_version "dev-python/pandas[${PYTHON_USEDEP}]"; then
+ EPYTEST_IGNORE+=( jsonpickle/ext/pandas.py )
+ fi
+
+ epytest
+}
+
+pkg_postinst() {
+ # Unpackaged optional backends: yajl, demjson
+ optfeature "encoding numpy-based data" dev-python/numpy
+ optfeature "encoding pandas objects" dev-python/pandas
+ optfeature "fast JSON backend" dev-python/simplejson
+}