summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-03 06:02:51 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-03 06:02:51 +0200
commita5b4082292698368d0f669ac55f1c0a1aa7af2b5 (patch)
treed872c124379a9adaa7cf040a721ece2a06451feb /dev-python
parentdev-python/scipy: Add a patch for Cython-3 (diff)
downloadgentoo-a5b4082292698368d0f669ac55f1c0a1aa7af2b5.tar.gz
gentoo-a5b4082292698368d0f669ac55f1c0a1aa7af2b5.tar.bz2
gentoo-a5b4082292698368d0f669ac55f1c0a1aa7af2b5.zip
dev-python/pypdf: Bump to 3.12.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pypdf/Manifest1
-rw-r--r--dev-python/pypdf/pypdf-3.12.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/pypdf/Manifest b/dev-python/pypdf/Manifest
index 7f3cf4a96278..b86c93da8eb6 100644
--- a/dev-python/pypdf/Manifest
+++ b/dev-python/pypdf/Manifest
@@ -1,5 +1,6 @@
DIST pypdf-3.10.0.gh.tar.gz 7558639 BLAKE2B 4c3bc668ae750e1ff78837459704fa24fbc8cdd90bb43c28e60140b3f3d2282d609460ec184d439d3121b284307236b8768ebc121679ed19e43efe43c5da5533 SHA512 e34072c21aa2caca7a3c99c754175fa3ccd42f69dbaaa92c52fbf1e1fb5e70245d3571305987d79f897769726c075d98313e07e9acf7817763a2522b16ddc424
DIST pypdf-3.11.0.gh.tar.gz 7560736 BLAKE2B 171c242e819cb417004aaba6341a38e8b89eec1346d6bdf899320da220f6368e38fee268ae2a90e308fd142c33411acf89a82bf00aa1220c9c697c052255e7a1 SHA512 f2f8d6e1035a8b2d14d6750c64e46e14b119324e08a3f808e5cacb7144c5c3ce3db65248010d13d520bc57915ea0f5f9a4b78db72ae430b46f614b2c0d5f7359
DIST pypdf-3.11.1.gh.tar.gz 7560136 BLAKE2B fa6b415b2b98a5e4a8d67bfdf38a81922ddf724fdbb17581c035294565e7c953e9e9ad190dcdc4172ba78b6e8e7c7a4df008e6ca30f88337aad5ee04523e2b81 SHA512 061265b4263396c3a204a8741cd8200408ca0c00520b022d54acb10a2902ed61a54a7990d47c91a9b292653ef98005c00084f0d61f7e79b5e8f617896dbaa7bb
+DIST pypdf-3.12.0.gh.tar.gz 7560403 BLAKE2B 1595020104ee6d93027ad9ff3f58bbdec33c8f4a407a29ca110a01b506a5aaf0808d75d727099930abd98406a5cc7e66f3529974b5920a1ca4382ed02367dc51 SHA512 fa196aac50c24f3459725c77ca346b1ac2a7aa343ae1f2277a42401b5335dd4c7f827dafcd8aa8b099c72fe332107c091cc5fe476f593fdc9ea146aaa204cdcd
DIST pypdf-sample-files-2cf1e75af7bcb9c097deae6fb112c715d4721744.gh.tar.gz 10226061 BLAKE2B a9b32d6cd3d22bbc0aee54ca3e914c4d2eb2a9a44a1a508e54e0a8fbcb5fad9ab05e72cf66553a1b5595131104ff22dea115d2804d2970200c4cf5f808532174 SHA512 f064f0468b07bf705a1d0f3a0fc6fe535c234a39408dca268f223e7c3548e66f599a4e67156e7848b70e9a3bd1bc2756395dd93b0c828ee08fe2bb8833f2b196
DIST pypdf-sample-files-69b31cff6b183a42f9081709ef9bee4047976f56.gh.tar.gz 9044391 BLAKE2B 9a9bcfbacabf3c80073a440f54736728cba4ea92d1a817ce98bcaf9375340d95e453f45207f53ac878ef5c13bc4ca7d0d4488b79f205f396e960ed042680ca01 SHA512 32b4572d60a0aadba02485f11c84712c1f5f0a75f7acd6fb27f1df00cb2a8ae338a1001e6519f66c248efbd129aba1a2ad568e930ce90bd542c8dc58f383386a
diff --git a/dev-python/pypdf/pypdf-3.12.0.ebuild b/dev-python/pypdf/pypdf-3.12.0.ebuild
new file mode 100644
index 000000000000..daa02ffcff0c
--- /dev/null
+++ b/dev-python/pypdf/pypdf-3.12.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+SAMPLE_COMMIT=2cf1e75af7bcb9c097deae6fb112c715d4721744
+DESCRIPTION="Python library to work with PDF files"
+HOMEPAGE="
+ https://pypi.org/project/pypdf/
+ https://github.com/py-pdf/pypdf/
+"
+SRC_URI="
+ https://github.com/py-pdf/pypdf/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ test? (
+ https://github.com/py-pdf/sample-files/archive/${SAMPLE_COMMIT}.tar.gz
+ -> ${PN}-sample-files-${SAMPLE_COMMIT}.gh.tar.gz
+ )
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pillow[jpeg,jpeg2k,tiff,${PYTHON_USEDEP}]
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # rely on -Werror
+ tests/test_utils.py::test_deprecate_no_replacement
+ tests/test_workflows.py::test_orientations
+ # TODO: requires fpdf
+ tests/test_page.py::test_compression
+)
+
+src_unpack() {
+ default
+ if use test; then
+ mv "sample-files-${SAMPLE_COMMIT}"/* "${S}"/sample-files/ || die
+ fi
+}
+
+python_test() {
+ epytest -o addopts= -m "not enable_socket"
+}