summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarri Nieminen <moikkis@gmail.com>2017-12-07 10:36:19 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-12-08 23:18:02 +0100
commita32c4c1fac7ea8467987e645b92e303090ace7af (patch)
tree9ad85e99822c5faf7eae7c17cbe99ef91c6badc7 /dev-python
parentdev-perl/Net-SSH-Perl: add missing die. (diff)
downloadgentoo-a32c4c1fac7ea8467987e645b92e303090ace7af.tar.gz
gentoo-a32c4c1fac7ea8467987e645b92e303090ace7af.tar.bz2
gentoo-a32c4c1fac7ea8467987e645b92e303090ace7af.zip
dev-python/parse-type: remove old.
Has missing die Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/parse-type/parse-type-0.3.4.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-python/parse-type/parse-type-0.3.4.ebuild b/dev-python/parse-type/parse-type-0.3.4.ebuild
deleted file mode 100644
index aa50d715f039..000000000000
--- a/dev-python/parse-type/parse-type-0.3.4.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 python3_4 )
-
-inherit distutils-r1
-
-DESCRIPTION="Simplifies to build parse types based on the parse module"
-HOMEPAGE="https://github.com/jenisys/parse_type"
-
-MY_PN="${PN/-/_}"
-MY_P="${MY_PN}-${PV}"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-runner[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="
- >=dev-python/parse-1.6[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' 'python2*' 'python3_3')
-"
-
-python_test() {
- py.test tests || "Tests failed under ${EPYTHON}"
-}