summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-01 06:03:42 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-01 06:15:46 +0200
commit9e9c3f2e5b5d4d20fc0b0eb424171f0cceed17e4 (patch)
treeeea392d47a205ed61982f6344b867fbc61261f3b /dev-python
parentdev-python/x-wr-timezone: Bump to 1.0.1 (diff)
downloadgentoo-9e9c3f2e5b5d4d20fc0b0eb424171f0cceed17e4.tar.gz
gentoo-9e9c3f2e5b5d4d20fc0b0eb424171f0cceed17e4.tar.bz2
gentoo-9e9c3f2e5b5d4d20fc0b0eb424171f0cceed17e4.zip
dev-python/recurring-ical-events: Bump to 3.3.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/recurring-ical-events/Manifest1
-rw-r--r--dev-python/recurring-ical-events/recurring-ical-events-3.3.2.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/recurring-ical-events/Manifest b/dev-python/recurring-ical-events/Manifest
index bc3f11f146f9..675908737d7a 100644
--- a/dev-python/recurring-ical-events/Manifest
+++ b/dev-python/recurring-ical-events/Manifest
@@ -1 +1,2 @@
DIST python-recurring-ical-events-3.3.1.gh.tar.gz 478584 BLAKE2B 79728b5a1aed1495e468cf0ad86ee1a130b6f5100576ecae93ad2d278ae998fb4a89825c046800c6064eda674499bd5ca2cc29a2031c41486f23155de6d67522 SHA512 dd2b4de334ef48efaf201b833cf21cc25be3a39f9c06466a6a25a0f8402d01d7262c4030ba0878d74efb6b3011bdcf5c7fcea5b114ab908c7fa30a37c3ba6f88
+DIST python-recurring-ical-events-3.3.2.gh.tar.gz 478532 BLAKE2B 70bcad67a8921f0a6b1483d7bbadcb7a3a9e61547601c4d679120237572fa3034743d655d85e68dfa6386396acd487ee52edb57d1fcdcc6aeb05eee7c4ca5820 SHA512 f5c59235a3746eb95af649517b2e06d9602488e42bcfa28e2609cf42b2e325d2e7e8d3b86e1cee9b83364d55f3e2e90f6bb36828d0068ad8ad146575be4fc584
diff --git a/dev-python/recurring-ical-events/recurring-ical-events-3.3.2.ebuild b/dev-python/recurring-ical-events/recurring-ical-events-3.3.2.ebuild
new file mode 100644
index 000000000000..61966884487f
--- /dev/null
+++ b/dev-python/recurring-ical-events/recurring-ical-events-3.3.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+MY_P=python-${P}
+DESCRIPTION="Repeat ICalendar events by RRULE, RDATE and EXDATE"
+HOMEPAGE="
+ https://github.com/niccokunzmann/python-recurring-ical-events/
+ https://pypi.org/project/recurring-ical-events/
+"
+SRC_URI="
+ https://github.com/niccokunzmann/python-recurring-ical-events/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/icalendar-7[${PYTHON_USEDEP}]
+ >=dev-python/icalendar-5.0.9[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
+ <dev-python/x-wr-timezone-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/x-wr-timezone-1.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/icalendar-6[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2023.3[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ test/test_readme.py
+)