summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-16 17:38:54 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-16 17:38:54 +0100
commit9bc176c29288d72cb3135a0b7952a632b4e6564f (patch)
tree667f18fc2f8ad9f9602567fce0ba483704429073 /dev-python
parentdev-python/jupyter-events: Enable pypy3 (diff)
downloadgentoo-9bc176c29288d72cb3135a0b7952a632b4e6564f.tar.gz
gentoo-9bc176c29288d72cb3135a0b7952a632b4e6564f.tar.bz2
gentoo-9bc176c29288d72cb3135a0b7952a632b4e6564f.zip
dev-python/jedi: Enable pypy3
Sponsored-by: Ex Makhina, Inc. <info-gentoo@exmakhina.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jedi/jedi-0.19.1.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/dev-python/jedi/jedi-0.19.1.ebuild b/dev-python/jedi/jedi-0.19.1.ebuild
index 6b31c5b89bd8..3cfa00a0c4e2 100644
--- a/dev-python/jedi/jedi-0.19.1.ebuild
+++ b/dev-python/jedi/jedi-0.19.1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
inherit distutils-r1
@@ -65,6 +65,17 @@ python_test() {
test/test_inference/test_imports.py::test_os_issues
)
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ test/test_api/test_api.py::test_preload_modules
+ test/test_api/test_interpreter.py::test_param_infer_default
+ test/test_inference/test_compiled.py::test_next_docstr
+ test/test_inference/test_compiled.py::test_time_docstring
+ )
+ ;;
+ esac
+
# some plugin breaks case-insensitivity on completions
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
# django and pytest tests are very version dependent