summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-15 08:55:16 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-15 17:11:35 +0100
commit75c5d9ccacdd141b7be688fd963acbaedbbe4c74 (patch)
tree633a228b21b086cff300cfb8ca5560f5eca1695a /dev-python
parentdev-python/natsort: Bump to 8.0.2 (diff)
downloadgentoo-75c5d9ccacdd141b7be688fd963acbaedbbe4c74.tar.gz
gentoo-75c5d9ccacdd141b7be688fd963acbaedbbe4c74.tar.bz2
gentoo-75c5d9ccacdd141b7be688fd963acbaedbbe4c74.zip
dev-python/pythran: Bump to 0.11.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pythran/Manifest1
-rw-r--r--dev-python/pythran/pythran-0.11.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/pythran/Manifest b/dev-python/pythran/Manifest
index 6b22a3992ef2..65f819485dab 100644
--- a/dev-python/pythran/Manifest
+++ b/dev-python/pythran/Manifest
@@ -1 +1,2 @@
DIST pythran-0.10.0.gh.tar.gz 3614984 BLAKE2B 82686479d475c6814392eb6c34e2d765ba36c88f9de3119f38c81b3f09d07acce8f5ab11b31114c13a1aa3bebd3699c540edcc6203401a007caf02c960a4733b SHA512 3d48d6f12fcd0317cb756eee18ad359057e4daee1a496023253b26febd2acf0fd22c3b4976bc8552a137d25052e4feaacf1917c5dc84414e9fbed66dff5c1614
+DIST pythran-0.11.0.gh.tar.gz 3582011 BLAKE2B 532afe9edd84d2699254bcad330dc03fcda4defce73997ec9feecf1a9e0c8f4fd407a5c4ebae7e10f96463a43453137953dc3e4df010ae7fb63d540d41b79f53 SHA512 bd703148f26a0511f5a21e691e62f4e9b7bf5a92548f8ac837b2d24135917b71b052941180c9801f29c457018eb57e5f5107a509d6815d8dd8ddab1b8626b1a1
diff --git a/dev-python/pythran/pythran-0.11.0.ebuild b/dev-python/pythran/pythran-0.11.0.ebuild
new file mode 100644
index 000000000000..2e5c661cd0ed
--- /dev/null
+++ b/dev-python/pythran/pythran-0.11.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1 multiprocessing
+
+MY_P=${P/_p/.post}
+DESCRIPTION="Ahead of Time compiler for numeric kernels"
+HOMEPAGE="
+ https://pypi.org/project/pythran/
+ https://github.com/serge-sans-paille/pythran/"
+SRC_URI="
+ https://github.com/serge-sans-paille/pythran/archive/${PV/_p/.post}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ =dev-python/beniget-0.4*[${PYTHON_USEDEP}]
+ =dev-python/gast-0.5*[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/ply-3.4[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ virtual/cblas
+ )"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.10.0-tests-werror.patch
+)
+
+src_prepare() {
+ sed -i -e '/pytest-runner/d' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x COLUMNS=80
+ epytest -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}