summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-13 06:18:44 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-04-13 08:35:06 +0300
commit6d629bf96e41242ddfdbc0a8cc3bbacb9b0392e9 (patch)
tree7b4f37410b945038e544c617e5ab8e3462c472e6 /dev-python
parentdev-python/black: Bump to 24.4.0 (diff)
downloadgentoo-6d629bf96e41242ddfdbc0a8cc3bbacb9b0392e9.tar.gz
gentoo-6d629bf96e41242ddfdbc0a8cc3bbacb9b0392e9.tar.bz2
gentoo-6d629bf96e41242ddfdbc0a8cc3bbacb9b0392e9.zip
dev-python/zeroconf: Bump to 0.132.2
Signed-off-by: Michał Górny <mgorny@gentoo.org> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/zeroconf/Manifest1
-rw-r--r--dev-python/zeroconf/zeroconf-0.132.2.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/zeroconf/Manifest b/dev-python/zeroconf/Manifest
index 6afd524da9d6..95e2af190e39 100644
--- a/dev-python/zeroconf/Manifest
+++ b/dev-python/zeroconf/Manifest
@@ -1,2 +1,3 @@
DIST zeroconf-0.131.0.tar.gz 169253 BLAKE2B 64247bdca5f8a226e73078b0395fa273649d3baea54fe52c350bf5117527e4290974843385f5b23568a6350bb41fa0af13a6999ef4e880fc42952dde21126296 SHA512 7b7f5494a589306c458dc4fedd940aab86918e9979d5b9f0a466d28b74795c83351f82fdf501a983e9df3e32a8be9a88af3486e79ade23ab73d889610331d89a
DIST zeroconf-0.132.0.tar.gz 170270 BLAKE2B 2ef40ab7d3aafb21f3b82b2e47598034ab821218f80082f26be3e41ac1197ea52a57657e45f38b41a8113164fbde2a8839264c9284c82b64327c443afad1726e SHA512 b8ccbb6f196db9404361e4ec85bc2a9f9801335a188ba6e4f1090afe1f042d82b69545f5db9b8c5d99720f1a7fbc77029ff0f624b8d17837b3dc8b41029e56a7
+DIST zeroconf-0.132.2.tar.gz 170698 BLAKE2B 7c76e2a00571a19b23f288dc1183da6ce274ebdf3f64f323e282f444011f7cbf90a63e02a991936a2cfa2d227568b31444b8f61f1110588638d4e888dd8749a6 SHA512 686cdfd2f32c6bad03fb5fd287b1e22f2f0b5099a8971dcff1d9fca7e63bc8069b195feb97be710c20fae8c524ab92143e395cdfec26ede103295d1aa4d32a8f
diff --git a/dev-python/zeroconf/zeroconf-0.132.2.ebuild b/dev-python/zeroconf/zeroconf-0.132.2.ebuild
new file mode 100644
index 000000000000..be589608aa7b
--- /dev/null
+++ b/dev-python/zeroconf/zeroconf-0.132.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
+HOMEPAGE="
+ https://github.com/python-zeroconf/python-zeroconf/
+ https://pypi.org/project/zeroconf/
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/ifaddr-0.1.7[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/async-timeout-3.0.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+# the build system uses custom build script that uses distutils to build
+# C extensions, sigh
+BDEPEND="
+ >=dev-python/cython-3.0.8[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-65.6.3[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export REQUIRE_CYTHON=1
+
+python_test() {
+ local -x SKIP_IPV6=1
+ local EPYTEST_DESELECT=(
+ # network
+ tests/test_core.py::Framework::test_close_multiple_times
+ tests/test_core.py::Framework::test_launch_and_close
+ tests/test_core.py::Framework::test_launch_and_close_context_manager
+
+ # fragile to timeouts (?)
+ tests/services/test_browser.py::test_service_browser_expire_callbacks
+ tests/utils/test_asyncio.py::test_run_coro_with_timeout
+ )
+
+ epytest -o addopts=
+}