summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-31 04:55:43 +0200
committerMichał Górny <mgorny@gentoo.org>2024-03-31 04:59:06 +0200
commit24859d903d3eb861f9d73f451a0259242a6cda0d (patch)
tree6bf24fac724f87b56dfa97567819347a27270589 /dev-python
parentdev-python/recurring-ical-events: Remove old (diff)
downloadgentoo-24859d903d3eb861f9d73f451a0259242a6cda0d.tar.gz
gentoo-24859d903d3eb861f9d73f451a0259242a6cda0d.tar.bz2
gentoo-24859d903d3eb861f9d73f451a0259242a6cda0d.zip
dev-python/recurring-ical-events: Bump to 2.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/recurring-ical-events/Manifest1
-rw-r--r--dev-python/recurring-ical-events/recurring-ical-events-2.2.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/recurring-ical-events/Manifest b/dev-python/recurring-ical-events/Manifest
index ff959975b3b2..e50506d15bb8 100644
--- a/dev-python/recurring-ical-events/Manifest
+++ b/dev-python/recurring-ical-events/Manifest
@@ -1 +1,2 @@
DIST python-recurring-ical-events-2.1.3.gh.tar.gz 329303 BLAKE2B c034fa558629bb8b3c6a901278d14a91826c3dfc805f6960936cd6dc1b219aff027615b05501c85767ab554112f6edf2a2467ced220bd92a7ac493673ca02ffe SHA512 1852b5ed09d1c531ac969aac338893e0409a54d6b0d59e15dbdcbe2a5f97f111c1c01272fa5df640d26c1a12fbc5f284e35c3e10aed0f16a842fe8a6a54462a7
+DIST python-recurring-ical-events-2.2.0.gh.tar.gz 332176 BLAKE2B 85eb127e4c8e505f21c135e9241353aee33ae9a5087fb0fb2c2bf9b6a0e913f36a5077569c76c3b92d196e506d8c2be83806a2f8e8554b957a7ee84a1145f316 SHA512 ba5a3b22728d73a392e071d0b1b5363ebf94f25dbe00728fe944d1c7dbb2998b90550756b3ac5e8c51ef310ee269b90f1345ac8380ab8a89bfb7b24f5797ae4c
diff --git a/dev-python/recurring-ical-events/recurring-ical-events-2.2.0.ebuild b/dev-python/recurring-ical-events/recurring-ical-events-2.2.0.ebuild
new file mode 100644
index 000000000000..b1d8fa71740b
--- /dev/null
+++ b/dev-python/recurring-ical-events/recurring-ical-events-2.2.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=python-${P}
+DESCRIPTION="Repeat ICalendar events by RRULE, RDATE and EXDATE"
+HOMEPAGE="
+ https://github.com/niccokunzmann/python-recurring-ical-events/
+ https://pypi.org/project/recurring-ical-events/
+"
+SRC_URI="
+ https://github.com/niccokunzmann/python-recurring-ical-events/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/icalendar-6[${PYTHON_USEDEP}]
+ >=dev-python/icalendar-5.0.9[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2023.3[${PYTHON_USEDEP}]
+ <dev-python/x-wr-timezone-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/x-wr-timezone-0.0.5[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ test/test_readme.py
+)
+
+EPYTEST_DESELECT=(
+ # a test checking if tzdata package is installed that is apparently
+ # needed for other tests, except it isn't
+ test/test_zoneinfo_issue_57.py::test_zoneinfo_must_be_installed_if_it_is_possible
+)