summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <william.hubbs@sony.com>2019-03-07 15:55:24 -0600
committerWilliam Hubbs <williamh@gentoo.org>2019-03-07 15:57:12 -0600
commit0a5d69bc6cbccb7c2681fa442c2417991aaad5c9 (patch)
tree088cebea66a6f009adc7648ae9a19ceaa5e66643 /dev-python
parentx11-plugins/wmweather+: x86 stable (bug #678588) (diff)
downloadgentoo-0a5d69bc6cbccb7c2681fa442c2417991aaad5c9.tar.gz
gentoo-0a5d69bc6cbccb7c2681fa442c2417991aaad5c9.tar.bz2
gentoo-0a5d69bc6cbccb7c2681fa442c2417991aaad5c9.zip
dev-python/pytest-testmon: take TDD to a new level with py.test and testmon
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-testmon/Manifest1
-rw-r--r--dev-python/pytest-testmon/metadata.xml8
-rw-r--r--dev-python/pytest-testmon/pytest-testmon-0.9.15.ebuild26
3 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pytest-testmon/Manifest b/dev-python/pytest-testmon/Manifest
new file mode 100644
index 000000000000..b56efbe0dbee
--- /dev/null
+++ b/dev-python/pytest-testmon/Manifest
@@ -0,0 +1 @@
+DIST pytest-testmon-0.9.15.tar.gz 32468 BLAKE2B 72678f4a5ed9bbc1ee6a4ec611da105554856454dcd3a3f199084645977d7ce461697218c460f9ae3b5a56bd90843822e5e88c54fb43f55a12f2c31d4ea53658 SHA512 fb414c492188f59e34a5f940e9f378cc841dd9de311738a0238980318261f51b869c30e1218e3219dabf8c438f28bcb9b10f751c07240b533ead537f4b6d8d4e
diff --git a/dev-python/pytest-testmon/metadata.xml b/dev-python/pytest-testmon/metadata.xml
new file mode 100644
index 000000000000..c36c37139fad
--- /dev/null
+++ b/dev-python/pytest-testmon/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/pytest-testmon/pytest-testmon-0.9.15.ebuild b/dev-python/pytest-testmon/pytest-testmon-0.9.15.ebuild
new file mode 100644
index 000000000000..c5e588074fd7
--- /dev/null
+++ b/dev-python/pytest-testmon/pytest-testmon-0.9.15.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="take TDD to a new level with py.test and testmon"
+HOMEPAGE="https://github.com/tarpas/pytest-testmon"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]
+dev-python/coverage[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ distutils_install_for_testing
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}