summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-04-12 08:10:43 -0400
committerTim Harder <radhermit@gentoo.org>2017-04-12 08:10:43 -0400
commitb56af081364b094a3071d5ead56c405f6074fd3d (patch)
tree204edd900020b22ca184f67ffca3eec0b99e54d7 /dev-python/xcffib
parentdev-python/trollius: remove old (diff)
downloadgentoo-b56af081364b094a3071d5ead56c405f6074fd3d.tar.gz
gentoo-b56af081364b094a3071d5ead56c405f6074fd3d.tar.bz2
gentoo-b56af081364b094a3071d5ead56c405f6074fd3d.zip
dev-python/xcffib: version bump to 0.5.1
Diffstat (limited to 'dev-python/xcffib')
-rw-r--r--dev-python/xcffib/Manifest1
-rw-r--r--dev-python/xcffib/xcffib-0.5.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/xcffib/Manifest b/dev-python/xcffib/Manifest
index ed8489fc96b6..f8cbac2a05a8 100644
--- a/dev-python/xcffib/Manifest
+++ b/dev-python/xcffib/Manifest
@@ -1,2 +1,3 @@
DIST xcffib-0.4.0.tar.gz 74715 SHA256 94a3d3d48289a7e9e0687b1f9a5f69de6e6449ac98df0f79773b286a72f79f8a SHA512 ac144ffdfb559ae2ee8d4a23c937989ca4e28f913b2d27f1240725c8398ede1a7a010a0d861998151923d235d5e04799d8df8496c9ec8005a2286825dcd59bd7 WHIRLPOOL f67aba9f217a2aa408945f4f2703853385ce8170d069660f9433410c13ca41bbf9ba5fd9729509192996d34d934626a1c0f91e08a64e44b4aef43fb4e88b5c74
DIST xcffib-0.4.2.tar.gz 80441 SHA256 7f4210f1ee51bb6f87e747438699fcf449ece2cb354d106be474997e479cacb8 SHA512 df9d5e9500cb3ea9765d4f887bdc018a99c285eff5aa4c922cb59da89bd04640b6ba9d7a3b83cfa999bdc3749f438b1a4b336117e2885fe2e27d346439839a7e WHIRLPOOL 4670e8a2179ccf149bb91e415c5ed81a68268f898fe29a4c0918c27d1a2647736587ab5aa7ba268608defe6d4c0655a94120dbacaa3c0970faed87379412a609
+DIST xcffib-0.5.1.tar.gz 81274 SHA256 c0f8daf5375df1df2dbccd1066f464831cf3dd69d58dd851ada8d85d72b5eb25 SHA512 ed13a43e301c6713c3831261bd94444d3961f805c39cc72dbe05f986eafb24e4f53f653045b84b57b4046a3ac763b20bd661298af5e6cc57978c57d68d2a0a39 WHIRLPOOL 7b4c31737324550b78fa0755c1a3b58cdf8f0b1aaee39feecce4a0e8759208bdbf9b121c76ed558c1360b214cc833f20d50612deb835e46b8681bb652f0e802e
diff --git a/dev-python/xcffib/xcffib-0.5.1.ebuild b/dev-python/xcffib/xcffib-0.5.1.ebuild
new file mode 100644
index 000000000000..febf78fc0355
--- /dev/null
+++ b/dev-python/xcffib/xcffib-0.5.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A drop in replacement for xpyb, an XCB python binding"
+HOMEPAGE="https://github.com/tych0/xcffib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+IUSE="test"
+
+COMMON_DEPEND="x11-libs/libxcb"
+RDEPEND="
+ $(python_gen_cond_dep '>=dev-python/cffi-1.1:=[${PYTHON_USEDEP}]' 'python*')
+ $(python_gen_cond_dep '>=virtual/pypy-2.6.0' pypy )
+ dev-python/six[${PYTHON_USEDEP}]
+ ${COMMON_DEPEND}"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${COMMON_DEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ x11-apps/xeyes
+ )"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.4.2-test-imports.patch )
+
+python_test() {
+ nosetests -d -v || die
+}