summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-15 08:12:25 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-15 13:13:06 +0200
commit77929b7860b0a4aabba29930e0c54be0fa5fa5b9 (patch)
treed0b2e991f1fff409f40b5cf7d08eb6acf57a48fd /dev-python/xarray
parentmedia-sound/abcmidi: Stabilize 2023.03.15 x86, #904358 (diff)
downloadgentoo-77929b7860b0a4aabba29930e0c54be0fa5fa5b9.tar.gz
gentoo-77929b7860b0a4aabba29930e0c54be0fa5fa5b9.tar.bz2
gentoo-77929b7860b0a4aabba29930e0c54be0fa5fa5b9.zip
dev-python/xarray: Bump to 2023.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xarray')
-rw-r--r--dev-python/xarray/Manifest1
-rw-r--r--dev-python/xarray/xarray-2023.4.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/xarray/Manifest b/dev-python/xarray/Manifest
index b84eed4df25d..75e2ae639b89 100644
--- a/dev-python/xarray/Manifest
+++ b/dev-python/xarray/Manifest
@@ -1,2 +1,3 @@
DIST xarray-2023.2.0.tar.gz 3070514 BLAKE2B 00b08bb75878eed1aa82ac18ae5bc468d87812c90991f95b238048d53535dd884a943a068aec4114ba83c8e3cf1a37570b86ce5557fb33dc43f088a51916b92d SHA512 46b1e29e98a7c1bbe3275bc2fd39b0e5561319b4b9c6bf468c434880c9013c1dd9560b7281bd1b148ba8557cafe91ddf0ac56e5c038f1e995067ff1774162ab2
DIST xarray-2023.3.0.tar.gz 3686167 BLAKE2B b9c2e04d0278e383aef17280e74863244d458324c01ac59a453e72196d65cad8fbca9f8f99a33b6db66637f742e04e5615fa8fc6eed307f0511954a856f8f3d2 SHA512 c08269e6fc8cdd3123dd7c39e0b85959bafdc53a5da75187fc615281fb71212bf2e45059f8d18fa05339567a4827e7bb68de3e605416929a6a1defdb4ed393e3
+DIST xarray-2023.4.0.tar.gz 3689883 BLAKE2B 50c5a18eaf28fc3bc38bc322dc393ec3e6a66c2651341019b389ba950c01f3950ee13e0922568f29ac1e3650ca9fdb55aec5574abe8f733959f15151208ac09b SHA512 1bb5052cb48e4ecb2d4e9d88cb0a0d3b25469b762d34059b5f65a88c2cbd125711d9af8a46a16b3eff3783f7d7653118b44503f19512ebc89845449a92efe1d9
diff --git a/dev-python/xarray/xarray-2023.4.0.ebuild b/dev-python/xarray/xarray-2023.4.0.ebuild
new file mode 100644
index 000000000000..41b878f2455d
--- /dev/null
+++ b/dev-python/xarray/xarray-2023.4.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 multiprocessing pypi
+
+DESCRIPTION="N-D labeled arrays and datasets in Python"
+HOMEPAGE="
+ https://xarray.pydata.org/
+ https://github.com/pydata/xarray/
+ https://pypi.org/project/xarray/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/numpy-1.22[${PYTHON_USEDEP}]
+ >=dev-python/pandas-1.4[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+"
+# note: most of the test dependencies are optional
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/bottleneck[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+ !hppa? ( >=dev-python/scipy-1.4[${PYTHON_USEDEP}] )
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # warning-targeted tests are fragile and not important to end users
+ xarray/tests/test_backends.py::test_no_warning_from_dask_effective_get
+ # TODO: segv in netcdf4-python
+ 'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-5-5]'
+ 'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-5-None]'
+ 'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-None-5]'
+ 'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-None-None]'
+)
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p xdist.plugin -n "$(makeopts_jobs)"
+}