summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-01 19:18:22 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-01 19:33:40 +0200
commit4ab01ecfdef42c117a9a680ed8c1f5808dd5879d (patch)
tree07d55ed00a41d0aaed4b77fe78976184ed109409 /dev-python/xarray
parentdev-python/itsdangerous: Remove old (diff)
downloadgentoo-4ab01ecfdef42c117a9a680ed8c1f5808dd5879d.tar.gz
gentoo-4ab01ecfdef42c117a9a680ed8c1f5808dd5879d.tar.bz2
gentoo-4ab01ecfdef42c117a9a680ed8c1f5808dd5879d.zip
dev-python/xarray: Fix tests
Use GitHub tarball to have all data necessary for testing. Require <dev-python/numpy-2. Update deselects. Closes: https://bugs.gentoo.org/931057 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xarray')
-rw-r--r--dev-python/xarray/Manifest2
-rw-r--r--dev-python/xarray/xarray-2024.3.0.ebuild40
2 files changed, 15 insertions, 27 deletions
diff --git a/dev-python/xarray/Manifest b/dev-python/xarray/Manifest
index 47147154332b..341efb534101 100644
--- a/dev-python/xarray/Manifest
+++ b/dev-python/xarray/Manifest
@@ -1,3 +1,3 @@
+DIST xarray-2024.03.0.gh.tar.gz 3722922 BLAKE2B 52025d8ba196500ac989fc8ff85ae7578cae3602ede77b663350acf0e132d2d9358f3170c697aa2f158c2f3f3520607c23f9060356fec0942ebddb9ca3e039da SHA512 5d62c102a3fdf6dfc16182d3822386dc9edb75204dff9a9b8e3aa7bbe5b223c477f2a73f0a0e35de3454d9e738da6205da0c308bc778f8ffc9af80c20a49d6af
DIST xarray-2024.1.1.tar.gz 3614037 BLAKE2B cc50fbfa19a2c9229b85b8c7d5d0e7e7f6d3e5a484955fcc81aa0b37839a0b992d2c2f928e4097ca05c7b8294ed1061fbd0c1b7e7c65c9087a940dab97c520ce SHA512 b6447ca2c80b3a3091ac2baba648fef4faa79ffff272360e9726b318b517ede9d2717d1b6f77f03fdacf55527233f1a37c0d114901fe1a265d3e435cf293a487
DIST xarray-2024.2.0.tar.gz 3634288 BLAKE2B 8d1165360300da5af6d670947e5280052a3d8915768e02448b86ab38283d6d45258a2c4eb91982ba732ccedb3a7afc5f274116c9ee0072d35cdc5631b8a2ca50 SHA512 dcfe6d1f0edab8659664c5399b96d622d2e3df2f85bb7672d9afab6f74294a6449772efde080aaa7323f733c09cbd0f6f037e547be0afa79f39450eead777828
-DIST xarray-2024.3.0.tar.gz 3674424 BLAKE2B a255ad57329a322751fd96833128372e12b175ad11aa41eff21f0c188f7beb4e6ad0f904a4229d44f13222c45c127ac0be77e050ba5032255839733a084da5f0 SHA512 4c7490b2efb4ed1a7278c807f4d200d99407d21bd54287ca5d35300194049a82aef3d8fbedba8f180ddb0d554cbb3f8f63abbb01401d5904f6d29cfa729e2ab0
diff --git a/dev-python/xarray/xarray-2024.3.0.ebuild b/dev-python/xarray/xarray-2024.3.0.ebuild
index bf0e39683c59..f09c55d11e8c 100644
--- a/dev-python/xarray/xarray-2024.3.0.ebuild
+++ b/dev-python/xarray/xarray-2024.3.0.ebuild
@@ -6,7 +6,11 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..12} )
-inherit distutils-r1 pypi
+inherit distutils-r1
+
+# TODO: switch back to pypi in the next release
+MY_PV=2024.03.0
+MY_P=${PN}-${MY_PV}
DESCRIPTION="N-D labeled arrays and datasets in Python"
HOMEPAGE="
@@ -14,6 +18,11 @@ HOMEPAGE="
https://github.com/pydata/xarray/
https://pypi.org/project/xarray/
"
+SRC_URI="
+ https://github.com/pydata/xarray/archive/v${MY_PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
LICENSE="Apache-2.0"
SLOT="0"
@@ -21,6 +30,7 @@ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~riscv ~s390 ~x86"
IUSE="big-endian"
RDEPEND="
+ <dev-python/numpy-2[${PYTHON_USEDEP}]
>=dev-python/numpy-1.23[${PYTHON_USEDEP}]
>=dev-python/pandas-1.5[${PYTHON_USEDEP}]
>=dev-python/packaging-22[${PYTHON_USEDEP}]
@@ -42,32 +52,9 @@ distutils_enable_tests pytest
python_test() {
local EPYTEST_DESELECT=(
- # warning-targeted tests are fragile and not important to end users
- xarray/tests/test_backends.py::test_no_warning_from_dask_effective_get
- # TODO: segv in netcdf4-python
- 'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-5-5]'
- 'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-5-None]'
- 'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-None-5]'
- 'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-None-None]'
- xarray/tests/test_backends.py::TestDask::test_save_mfdataset_compute_false_roundtrip
- # TODO: broken
- xarray/tests/test_backends.py::TestNetCDF4Data
- xarray/tests/test_backends.py::TestNetCDF4ViaDaskData
- # hangs
- xarray/tests/test_backends.py::TestDask::test_dask_roundtrip
- # mismatches when pyarrow is installed
- # https://github.com/pydata/xarray/issues/8092
- xarray/tests/test_dask.py::TestToDaskDataFrame::test_to_dask_dataframe_2D
- xarray/tests/test_dask.py::TestToDaskDataFrame::test_to_dask_dataframe_not_daskarray
+ # requires dev-python/cftime
+ 'xarray/tests/test_coding_times.py::test_encode_cf_datetime_datetime64_via_dask[mixed-cftime-pandas-encoding-with-prescribed-units-and-dtype]'
)
- local EPYTEST_IGNORE=(
- # requires datatree_ subpackage that is not part of public API
- # https://github.com/pydata/xarray/issues/8768
- xarray/tests/datatree
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
-
if ! has_version ">=dev-python/scipy-1.4[${PYTHON_USEDEP}]" ; then
EPYTEST_DESELECT+=(
'xarray/tests/test_missing.py::test_interpolate_na_2d[coords1]'
@@ -87,5 +74,6 @@ python_test() {
)
fi
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
epytest
}