summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Karbowski <slashbeast@gentoo.org>2020-02-06 12:45:13 +0100
committerPiotr Karbowski <slashbeast@gentoo.org>2020-02-06 12:45:13 +0100
commit24ff445472b1a93d38cc46defa073c0335ef0de3 (patch)
treebfb1b475a038c9f8ed912e8294ba96400f0f27f0 /dev-python/whisper
parentsys-kernel/gentoo-sources: Linux patch 5.4.18 (diff)
downloadgentoo-24ff445472b1a93d38cc46defa073c0335ef0de3.tar.gz
gentoo-24ff445472b1a93d38cc46defa073c0335ef0de3.tar.bz2
gentoo-24ff445472b1a93d38cc46defa073c0335ef0de3.zip
Revert "dev-python/whisper: Remove old (drop to ~arch)"
Revert due to dev-python/carbon rdeps. This reverts commit 9b8c18d84129f39d68c2e9c813f9248f8f0836f1. Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Diffstat (limited to 'dev-python/whisper')
-rw-r--r--dev-python/whisper/Manifest3
-rw-r--r--dev-python/whisper/whisper-0.9.13.ebuild17
-rw-r--r--dev-python/whisper/whisper-0.9.15.ebuild17
-rw-r--r--dev-python/whisper/whisper-1.1.3.ebuild33
4 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/whisper/Manifest b/dev-python/whisper/Manifest
index d6c316848ac3..6a4b2f0f8a3e 100644
--- a/dev-python/whisper/Manifest
+++ b/dev-python/whisper/Manifest
@@ -1 +1,4 @@
+DIST whisper-0.9.13.tar.gz 14028 BLAKE2B 38c1d006c3b6334df8c18c7e5f695359912db225b72047c0549ba6ca786a1f8f2820a18957d8f0a9bdd07ffa723b9c12b3ddd501d88a65c55d3df6db241aa94e SHA512 b4b46bb7f31ecb766495f5f592fb2f9a754f5f38f83f071b533d4302b95808b9b4046bf7769bfa0d7713633344c7c693b57dd550b52acec4617257eba68634c1
+DIST whisper-0.9.15.tar.gz 15655 BLAKE2B d2f8a1333312038fdec2ed990c4657255242da74d68fb07aa1099fce345d95c15ea98a28a2a3a582b7972c6b67df9f0e2ea2280b9ba9168d65638548d53b8555 SHA512 bdc9d299ed713a3fc6104938c347682562d5f17a7f3650d823f9814410dc934899b81bb2f42f52e9cc25313d8ed33f7b4def6d8945561d63f6237492bda2a5e6
+DIST whisper-1.1.3.tar.gz 37716 BLAKE2B e0cad5c7ef8ca885cae2060838669d80e8b2e28d1039dce45fec601257c866d202a73279d923aff39781f71d7c9bfdc19300c991e7a5956af337d5ff18a37ede SHA512 cd2a1bece58ea4cb3f5df6adbe1966e1408c92a55b21bf7298d4b30fdd51780e236707cae1414d6c363a046a36870a6ac230ec30abe565fde9fbf17efc9e7cab
DIST whisper-1.1.5.tar.gz 38104 BLAKE2B ab36c91c00dd8e8e26b24c0c2967c661f0bd69f3dcb0e52763f6527a233f656a984c738be720c0b5f2d27fff08daa164db87f0ab693d360bd0c087cf6a408340 SHA512 dee42adf1824c876cf15e9e55101d90d08889fd6e267a89c18fdb4a7d4c5a3a0d4f6f24bb0fdeb974fd194046c17e00f71033ddb72c74c4d4ded0a937e82c8a9
diff --git a/dev-python/whisper/whisper-0.9.13.ebuild b/dev-python/whisper/whisper-0.9.13.ebuild
new file mode 100644
index 000000000000..e28808b7c7cc
--- /dev/null
+++ b/dev-python/whisper/whisper-0.9.13.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Fixed size round-robin style database"
+HOMEPAGE="https://github.com/graphite-project/whisper"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="amd64 x86"
+SLOT="0"
+IUSE=""
diff --git a/dev-python/whisper/whisper-0.9.15.ebuild b/dev-python/whisper/whisper-0.9.15.ebuild
new file mode 100644
index 000000000000..0011e84462d1
--- /dev/null
+++ b/dev-python/whisper/whisper-0.9.15.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Fixed size round-robin style database"
+HOMEPAGE="https://github.com/graphite-project/whisper"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86 ~x64-solaris"
+SLOT="0"
+IUSE=""
diff --git a/dev-python/whisper/whisper-1.1.3.ebuild b/dev-python/whisper/whisper-1.1.3.ebuild
new file mode 100644
index 000000000000..593f5228b98b
--- /dev/null
+++ b/dev-python/whisper/whisper-1.1.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python{2_7,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Fixed size round-robin style database"
+HOMEPAGE="https://github.com/graphite-project/whisper"
+# PyPI tarballs don't contain tests
+# https://github.com/graphite-project/whisper/pull/253
+SRC_URI="https://github.com/graphite-project/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86 ~x64-solaris"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ virtual/python-unittest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ py.test || die "tests failed with ${EPYTHON}"
+}