summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-11-05 22:33:10 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-11-05 22:34:56 +0200
commitb9874e35e3334ad39408074201706fd0e857c6fe (patch)
treec08bdbdc955f7a3d76b81365abb2cbbd47f16813 /dev-python/wheel
parentdev-python/wheel: add 0.38.2 (diff)
downloadgentoo-b9874e35e3334ad39408074201706fd0e857c6fe.tar.gz
gentoo-b9874e35e3334ad39408074201706fd0e857c6fe.tar.bz2
gentoo-b9874e35e3334ad39408074201706fd0e857c6fe.zip
dev-python/wheel: drop 0.38.1
This version had severe bug which was fixed in 0.38.2, so better to hide this release. Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/wheel')
-rw-r--r--dev-python/wheel/Manifest1
-rw-r--r--dev-python/wheel/wheel-0.38.1.ebuild66
2 files changed, 0 insertions, 67 deletions
diff --git a/dev-python/wheel/Manifest b/dev-python/wheel/Manifest
index db33035cbe69..ee175fb435c9 100644
--- a/dev-python/wheel/Manifest
+++ b/dev-python/wheel/Manifest
@@ -1,4 +1,3 @@
DIST wheel-0.37.1.gh.tar.gz 68751 BLAKE2B 55919649f82668565d3b5907d14d0758984bb7d29d8857807ad034288ed8c9e8660957dc16f418f18408e89a97cf0d3c30df874a17f56deb56918388b18246a7 SHA512 9493db2f29e16d17ca06a4d47854b3df5dfd17f21c77efd42befd54470858256fd59f56aa9585cbf0a09830927b657d546324f793e1b1153665bf0b74d0c0457
DIST wheel-0.38.0.gh.tar.gz 68696 BLAKE2B 38dbc8ba7cf67d202c6c98b277e590b3b31b46b698f59f988af1710e9fa6e5d2125378029475060cf3142cd9666bb318005619d085ea2e8b501bb10cd9694fe3 SHA512 0ffdf531c03d1f0866632002b163fdf8642b613604e74d1cfa5844e8c327946baf303bc0410fc7ec034f8a79cb4ad59536dfdaaa5cc8fa23a3b7d21faf5e6161
-DIST wheel-0.38.1.gh.tar.gz 69293 BLAKE2B 68f65a8a50e18e869106aa535faaebf6445bee8ccf31a78519ed325f1b98cbabc7e4a34028c0211324852163666481bc167eeeaee5f3febefbb008c9286f9d05 SHA512 1818b50a4ee50861aac3c9ac4058c5fee2de4a428ca04e7a9b1ce570dab6f1b64f4528f812aa23e87705ed15e360d0bd5b01523bd4360875c25054b1ccbf9179
DIST wheel-0.38.2.gh.tar.gz 69346 BLAKE2B 619da7f17d82837d70cb86bf6481738a4959c70f1be56ad68f87380f4f03efc588ada7af1b6892079833df50e4aa57f7453b811b616b8440e388bad701726572 SHA512 59a55e35f641dc6e97bcd58755ef39dd771f8ed442843321878054db3c54234befde368ae500a93fffde6ea1bbcb0e3981975b2c7574fc5a58693a70430e474b
diff --git a/dev-python/wheel/wheel-0.38.1.ebuild b/dev-python/wheel/wheel-0.38.1.ebuild
deleted file mode 100644
index 24e78cab73d7..000000000000
--- a/dev-python/wheel/wheel-0.38.1.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
-EAPI=7
-
-DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="A built-package format for Python"
-HOMEPAGE="
- https://github.com/pypa/wheel/
- https://pypi.org/project/wheel/
-"
-SRC_URI="
- https://github.com/pypa/wheel/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos ~x64-solaris"
-
-RDEPEND="
- dev-python/packaging[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/setuptools[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # unbundle packaging
- rm -r src/wheel/vendored || die
- sed -i -e 's:\.vendored\.::' src/wheel/*.py || die
- sed -i -e 's:wheel\.vendored\.::' tests/*.py || die
-
- distutils-r1_src_prepare
-}
-
-src_configure() {
- [[ -e pyproject.toml ]] &&
- die "Upstream added pyproject.toml, recheck"
- # write a custom pyproject.toml to ease setuptools bootstrap
- cat > pyproject.toml <<-EOF || die
- [build-system]
- requires = ["flit_core >=3.2,<4"]
- build-backend = "flit_core.buildapi"
-
- [project]
- name = "wheel"
- description = "A built-package format for Python"
- dynamic = ["version"]
-
- [project.scripts]
- wheel = "wheel.cli:main"
-
- [project.entry-points."distutils.commands"]
- bdist_wheel = "wheel.bdist_wheel:bdist_wheel"
- EOF
-}