summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-15 09:43:42 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-15 10:14:59 +0200
commit61c3bb52fd59cdc76c43225ba430af79461b40a2 (patch)
tree6ca897435b36b100c3bc21ede0ecbfabc5d248b7 /dev-python/webtest
parentdev-python/webob: Enable py3.13 (diff)
downloadgentoo-61c3bb52fd59cdc76c43225ba430af79461b40a2.tar.gz
gentoo-61c3bb52fd59cdc76c43225ba430af79461b40a2.tar.bz2
gentoo-61c3bb52fd59cdc76c43225ba430af79461b40a2.zip
dev-python/webtest: Enable py3.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/webtest')
-rw-r--r--dev-python/webtest/webtest-3.0.0-r2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/webtest/webtest-3.0.0-r2.ebuild b/dev-python/webtest/webtest-3.0.0-r2.ebuild
new file mode 100644
index 000000000000..1ff513b356f8
--- /dev/null
+++ b/dev-python/webtest/webtest-3.0.0-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN="WebTest"
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Helper to test WSGI applications"
+HOMEPAGE="
+ https://docs.pylonsproject.org/projects/webtest/en/latest/
+ https://github.com/Pylons/webtest/
+ https://pypi.org/project/WebTest/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/paste[${PYTHON_USEDEP}]
+ dev-python/pastedeploy[${PYTHON_USEDEP}]
+ >=dev-python/webob-1.2[${PYTHON_USEDEP}]
+ >=dev-python/waitress-0.8.5[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pyquery[${PYTHON_USEDEP}]
+ dev-python/wsgiproxy2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/legacy-cgi[${PYTHON_USEDEP}]
+ ' 3.13)
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/webtest-2.0.33-no-pylons-theme.patch"
+ "${FILESDIR}/webtest-3.0.0-python3.12-unittest.patch"
+)
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest