summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-03 08:42:58 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-03 08:42:58 +0200
commit6003b5c361ff80d60c738eef00dc0a033be5ae24 (patch)
tree0c797f7618ad553b433386b33ead5a8daded8804 /dev-python/virtualenv
parentdev-python/python-debian: Remove old (diff)
downloadgentoo-6003b5c361ff80d60c738eef00dc0a033be5ae24.tar.gz
gentoo-6003b5c361ff80d60c738eef00dc0a033be5ae24.tar.bz2
gentoo-6003b5c361ff80d60c738eef00dc0a033be5ae24.zip
dev-python/virtualenv: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/virtualenv')
-rw-r--r--dev-python/virtualenv/Manifest2
-rw-r--r--dev-python/virtualenv/virtualenv-20.16.3.ebuild106
-rw-r--r--dev-python/virtualenv/virtualenv-20.16.4.ebuild106
3 files changed, 0 insertions, 214 deletions
diff --git a/dev-python/virtualenv/Manifest b/dev-python/virtualenv/Manifest
index 761ed19fde49..3fb7f1316c6d 100644
--- a/dev-python/virtualenv/Manifest
+++ b/dev-python/virtualenv/Manifest
@@ -1,3 +1 @@
-DIST virtualenv-20.16.3.tar.gz 12219368 BLAKE2B 00a7d38db3e9d929e5f01eb020436cf5b917a10bca876ef4abe7a07f5e86a1b1930ed42acbac96d80375a78b660a70872ba6048c673a4ad4d51cafb7824d8f6d SHA512 d3a90bab9862ea2a70e1dc429dff98a729425858a2153281cba4ecaf13107e6c3a43781e8c96b1f2a6c1ddd797de86bcfee8129a698e45d20eed76432efba5a6
-DIST virtualenv-20.16.4.tar.gz 12223823 BLAKE2B 0ca7eafe9bfdfbf2c3b48c2bed454e55a38912c63f326720f14074e21a43ca05b4bd2ca916053e0bed1f3679e5f869771eda28b7ad0d8a87e6fcef149eba4ec0 SHA512 3319962368e5e7f9b79a3c91e909504adf4782fab63e6c25abd15168d6e859df41ebbfa8de94a8b28281cab67dc7cebd12f7289b6d522d6e873caa480dab5cda
DIST virtualenv-20.16.5.tar.gz 12223925 BLAKE2B 4f87f955d2d2c2b722d7a3699a74dc06aff7f2898203e87e607d1cabf182954fdf5eb2ba847d7b5641ded88e068d6e133441082703f8d874fbb92583f72eb6b1 SHA512 2d4f96057eb8fea5da07126bbc656306b8ebc2db1c82a84b784fcb82cd1959a571dc1f016dead9561e1d073a8b06e10f2e225d6484b363b960adaa64239826d3
diff --git a/dev-python/virtualenv/virtualenv-20.16.3.ebuild b/dev-python/virtualenv/virtualenv-20.16.3.ebuild
deleted file mode 100644
index f3f1dcc67007..000000000000
--- a/dev-python/virtualenv/virtualenv-20.16.3.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Virtual Python Environment builder"
-HOMEPAGE="
- https://virtualenv.pypa.io/en/stable/
- https://pypi.org/project/virtualenv/
- https://github.com/pypa/virtualenv/
-"
-SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-SLOT="0"
-
-RDEPEND="
- >=dev-python/distlib-0.3.5[${PYTHON_USEDEP}]
- >=dev-python/filelock-3.4.1[${PYTHON_USEDEP}]
- >=dev-python/platformdirs-2.4[${PYTHON_USEDEP}]
- >=dev-python/setuptools-63.2.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
-"
-# coverage is used somehow magically in virtualenv, maybe it actually
-# tests something useful
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/flaky[${PYTHON_USEDEP}]
- >=dev-python/pip-22.2.1[${PYTHON_USEDEP}]
- >=dev-python/pytest-freezegun-0.4.2[${PYTHON_USEDEP}]
- >=dev-python/pytest-mock-3.6.1[${PYTHON_USEDEP}]
- >=dev-python/pytest-timeout-2.1[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
- >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
- )
-"
-
-# (unpackaged deps)
-#distutils_enable_sphinx docs \
-# dev-python/sphinx-argparse \
-# dev-python/sphinx_rtd_theme \
-# dev-python/towncrier
-distutils_enable_tests pytest
-
-src_configure() {
- export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- tests/unit/activation/test_xonsh.py
- tests/unit/seed/embed/test_bootstrap_link_via_app_data.py::test_seed_link_via_app_data
- tests/unit/create/test_creator.py::test_cross_major
- # tests failing without python2 installed
- "tests/unit/create/test_creator.py::test_py_pyc_missing[True-False]"
- "tests/unit/create/test_creator.py::test_py_pyc_missing[False-False]"
- )
- [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
- 'tests/unit/create/test_creator.py::test_create_no_seed[root-pypy3-posix-copies-isolated]'
- 'tests/unit/create/test_creator.py::test_create_no_seed[root-pypy3-posix-copies-global]'
- 'tests/unit/create/test_creator.py::test_create_no_seed[venv-pypy3-posix-copies-isolated]'
- 'tests/unit/create/test_creator.py::test_create_no_seed[venv-pypy3-posix-copies-global]'
- 'tests/unit/create/test_creator.py::test_create_no_seed[root-venv-copies-isolated]'
- 'tests/unit/create/test_creator.py::test_create_no_seed[root-venv-copies-global]'
- 'tests/unit/create/test_creator.py::test_create_no_seed[venv-venv-copies-isolated]'
- 'tests/unit/create/test_creator.py::test_create_no_seed[venv-venv-copies-global]'
- 'tests/unit/create/test_creator.py::test_zip_importer_can_import_setuptools'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7.9-64-bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7.9--bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7.10-64-bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7.10--bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7-64-bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7--bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3-64-bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3--bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7.9-64-bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7.9--bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7.10-64-bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7.10--bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7-64-bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7--bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3-64-bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3--bin-]'
- )
- [[ ${EPYTHON} == python3.11 ]] && EPYTEST_DESELECT+=(
- # TODO
- tests/unit/discovery/py_info/test_py_info.py::test_py_info_setuptools
- tests/unit/discovery/py_info/test_py_info.py::test_custom_venv_install_scheme_is_prefered
- )
-
- epytest
-}
-
-pkg_postinst() {
- elog "Please note that while virtualenv package no longer supports"
- elog "Python 2.7, you can still create py2.7 virtualenvs via:"
- elog " $ virtualenv -p 2.7 ..."
-}
diff --git a/dev-python/virtualenv/virtualenv-20.16.4.ebuild b/dev-python/virtualenv/virtualenv-20.16.4.ebuild
deleted file mode 100644
index fe3fd6720779..000000000000
--- a/dev-python/virtualenv/virtualenv-20.16.4.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Virtual Python Environment builder"
-HOMEPAGE="
- https://virtualenv.pypa.io/en/stable/
- https://pypi.org/project/virtualenv/
- https://github.com/pypa/virtualenv/
-"
-SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-SLOT="0"
-
-RDEPEND="
- >=dev-python/distlib-0.3.5[${PYTHON_USEDEP}]
- >=dev-python/filelock-3.4.1[${PYTHON_USEDEP}]
- >=dev-python/platformdirs-2.4[${PYTHON_USEDEP}]
- >=dev-python/setuptools-63.2.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
-"
-# coverage is used somehow magically in virtualenv, maybe it actually
-# tests something useful
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/flaky[${PYTHON_USEDEP}]
- >=dev-python/pip-22.2.1[${PYTHON_USEDEP}]
- >=dev-python/pytest-freezegun-0.4.2[${PYTHON_USEDEP}]
- >=dev-python/pytest-mock-3.6.1[${PYTHON_USEDEP}]
- >=dev-python/pytest-timeout-2.1[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
- >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
- )
-"
-
-# (unpackaged deps)
-#distutils_enable_sphinx docs \
-# dev-python/sphinx-argparse \
-# dev-python/sphinx_rtd_theme \
-# dev-python/towncrier
-distutils_enable_tests pytest
-
-src_configure() {
- export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- tests/unit/activation/test_xonsh.py
- tests/unit/seed/embed/test_bootstrap_link_via_app_data.py::test_seed_link_via_app_data
- tests/unit/create/test_creator.py::test_cross_major
- # tests failing without python2 installed
- "tests/unit/create/test_creator.py::test_py_pyc_missing[True-False]"
- "tests/unit/create/test_creator.py::test_py_pyc_missing[False-False]"
- )
- [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
- 'tests/unit/create/test_creator.py::test_create_no_seed[root-pypy3-posix-copies-isolated]'
- 'tests/unit/create/test_creator.py::test_create_no_seed[root-pypy3-posix-copies-global]'
- 'tests/unit/create/test_creator.py::test_create_no_seed[venv-pypy3-posix-copies-isolated]'
- 'tests/unit/create/test_creator.py::test_create_no_seed[venv-pypy3-posix-copies-global]'
- 'tests/unit/create/test_creator.py::test_create_no_seed[root-venv-copies-isolated]'
- 'tests/unit/create/test_creator.py::test_create_no_seed[root-venv-copies-global]'
- 'tests/unit/create/test_creator.py::test_create_no_seed[venv-venv-copies-isolated]'
- 'tests/unit/create/test_creator.py::test_create_no_seed[venv-venv-copies-global]'
- 'tests/unit/create/test_creator.py::test_zip_importer_can_import_setuptools'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7.9-64-bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7.9--bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7.10-64-bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7.10--bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7-64-bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3.7--bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3-64-bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[PyPy-3--bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7.9-64-bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7.9--bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7.10-64-bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7.10--bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7-64-bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3.7--bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3-64-bin-]'
- 'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3--bin-]'
- )
- [[ ${EPYTHON} == python3.11 ]] && EPYTEST_DESELECT+=(
- # TODO
- tests/unit/discovery/py_info/test_py_info.py::test_py_info_setuptools
- tests/unit/discovery/py_info/test_py_info.py::test_custom_venv_install_scheme_is_prefered
- )
-
- epytest
-}
-
-pkg_postinst() {
- elog "Please note that while virtualenv package no longer supports"
- elog "Python 2.7, you can still create py2.7 virtualenvs via:"
- elog " $ virtualenv -p 2.7 ..."
-}