summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-17 07:04:48 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-17 07:28:49 +0200
commit02a1d1ceb26d99f3c982cfdc339cba2d2145449d (patch)
tree7ad4f9ee09e6850f4aea1062c8dbacd75d9c77dd /dev-python/vine
parentdev-python/kombu: Remove stray dep on dev-python/case (diff)
downloadgentoo-02a1d1ceb26d99f3c982cfdc339cba2d2145449d.tar.gz
gentoo-02a1d1ceb26d99f3c982cfdc339cba2d2145449d.tar.bz2
gentoo-02a1d1ceb26d99f3c982cfdc339cba2d2145449d.zip
dev-python/vine: EAPI 8, PEP517
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/vine')
-rw-r--r--dev-python/vine/vine-5.0.0-r1.ebuild (renamed from dev-python/vine/vine-5.0.0.ebuild)19
1 files changed, 12 insertions, 7 deletions
diff --git a/dev-python/vine/vine-5.0.0.ebuild b/dev-python/vine/vine-5.0.0-r1.ebuild
index 2572581272f6..95ef0d3d5b0b 100644
--- a/dev-python/vine/vine-5.0.0.ebuild
+++ b/dev-python/vine/vine-5.0.0-r1.ebuild
@@ -1,23 +1,28 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
-DISTUTILS_USE_SETUPTOOLS=bdepend
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
inherit distutils-r1
DESCRIPTION="Python Promises"
-HOMEPAGE="https://pypi.org/project/vine/ https://github.com/celery/vine"
+HOMEPAGE="
+ https://github.com/celery/vine/
+ https://pypi.org/project/vine/
+"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ~arm64 x86"
-DEPEND="
+BDEPEND="
test? (
>=dev-python/case-1.3.1[${PYTHON_USEDEP}]
- )"
+ )
+"
distutils_enable_tests pytest