summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-10 07:27:36 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-10 07:36:02 +0200
commit8d818df886f70dcf0323222ca1315fdece416048 (patch)
tree16d58e27a3aa8169a04d97023541cf036ed06285 /dev-python/uv
parentdev-python/miniupnpc: Remove old (diff)
downloadgentoo-8d818df886f70dcf0323222ca1315fdece416048.tar.gz
gentoo-8d818df886f70dcf0323222ca1315fdece416048.tar.bz2
gentoo-8d818df886f70dcf0323222ca1315fdece416048.zip
dev-python/uv: Bump to 0.1.31
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/uv')
-rw-r--r--dev-python/uv/Manifest2
-rw-r--r--dev-python/uv/uv-0.1.31.ebuild109
2 files changed, 111 insertions, 0 deletions
diff --git a/dev-python/uv/Manifest b/dev-python/uv/Manifest
index d2675244f055..36233c281cc5 100644
--- a/dev-python/uv/Manifest
+++ b/dev-python/uv/Manifest
@@ -10,3 +10,5 @@ DIST uv-0.1.24.gh.tar.gz 899637 BLAKE2B fab26ba9934fc5f586505b5ac1fa386c11f07e51
DIST uv-0.1.28-crates.tar.xz 64374368 BLAKE2B 6eceb9eba6d746007eb983ae704fc96496e29e86d219af19af01cafdb230bf2e5f572d07fac2ee5cdb42e5e553dbc266233425084acd98d73039a761c5e2907e SHA512 0966ece30f0ac1111ac6eb0d3f5aeea3a3a443962e0a477c66b62dae09374f1dccf1a0ac355d5c684e76759f64b6921ed192de8d0363682d0aafe1de31c019be
DIST uv-0.1.28.gh.tar.gz 925800 BLAKE2B 5e30573a198057261fe7716dc6dc5d8b7bd8700fabc4f061129d5e15475eeee96ea6424fc7321425348103796a2a6278118cc1c3399f8c3858c3816450e068c7 SHA512 3de0df5ca3c69bedc30d20c199251060a35d82ede8fa9f7f4907eee8e0bd55c7f10fbee0e870e1145c88c8526ab4729af4be393bc2a6508fa008050691ccf06a
DIST uv-0.1.29.gh.tar.gz 929681 BLAKE2B 647588a8c34d77cfa43ee7b459da19b6365c7ae451d2acb609c4ba1a67a0065be2d52925302a77cc716659b4cf217022bc9794d1d234c6aa43734dd5fca936ef SHA512 6a39347daa3922a594b318b7a56547d32b97fd81822265e8b0899c6cfe9e5e072e96b49fd2db74eeaf88f6f42a3b2c60aa7e7e338a38d0af4256a42a703a7d95
+DIST uv-0.1.31-crates.tar.xz 64759920 BLAKE2B 9404847d0a4bdaf77778fe7e75de4a6167c43a5f786357653f45f613984b2297f07a30dbd782d49ffd4f936276f2da61ecc543c6942c58ae2f3b6a5cb77212b0 SHA512 8c7440e52649b9a749d36ef5e7ed0a2be5df590d2cd6486559bc0ab289e87f5533927ddd82e86268b8cb86a41056557ec3acb3e4eface63439837243a2ab0b7a
+DIST uv-0.1.31.gh.tar.gz 938923 BLAKE2B c6be91911b557260df546bd708e572d4ea6688e40a0c978a598070e71bb989b77fdace1e5507dcc829e9e21714962c8e76ee2ec5dc95ae10a1ccaa562e4c70e7 SHA512 687f622bc93a0b4c967d53ab068d3f5442f7a3566495f89da252d3beb41a17be3dcf410f260f7e68bb1f5595f633ea61da7a68423f190d879e809c25e9e297cb
diff --git a/dev-python/uv/uv-0.1.31.ebuild b/dev-python/uv/uv-0.1.31.ebuild
new file mode 100644
index 000000000000..24a6f44759c7
--- /dev/null
+++ b/dev-python/uv/uv-0.1.31.ebuild
@@ -0,0 +1,109 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CRATES="
+"
+
+declare -A GIT_CRATES=(
+ [async_zip]='https://github.com/charliermarsh/rs-async-zip;1dcb40cfe1bf5325a6fd4bfcf9894db40241f585;rs-async-zip-%commit%'
+ [pubgrub]='https://github.com/astral-sh/pubgrub;c26e485213e39582c6f2e4d45c0328422670e7a7;pubgrub-%commit%'
+)
+
+inherit cargo check-reqs
+
+DESCRIPTION="A Python package installer and resolver, written in Rust"
+HOMEPAGE="
+ https://github.com/astral-sh/uv/
+ https://pypi.org/project/uv/
+"
+# pypi sdist misses scripts/, needed for tests
+SRC_URI="
+ https://github.com/astral-sh/uv/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ ${CARGO_CRATE_URIS}
+"
+if [[ ${PKGBUMPING} != ${PVR} ]]; then
+ CRATE_P=${P}
+ SRC_URI+="
+ https://dev.gentoo.org/~mgorny/dist/${CRATE_P}-crates.tar.xz
+ "
+fi
+
+# most of the code
+LICENSE="|| ( Apache-2.0 MIT )"
+# crates/pep508-rs is || ( Apache-2.0 BSD-2 ) which is covered below
+# Dependent crate licenses
+LICENSE+="
+ 0BSD Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD-2 BSD ISC MIT
+ MPL-2.0 Unicode-DFS-2016
+"
+# ring crate
+LICENSE+=" openssl"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="test"
+PROPERTIES="test_network"
+
+DEPEND="
+ dev-libs/libgit2:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=virtual/rust-1.77
+ test? (
+ dev-lang/python:3.8
+ dev-lang/python:3.9
+ dev-lang/python:3.10
+ dev-lang/python:3.11
+ dev-lang/python:3.12
+ )
+"
+
+QA_FLAGS_IGNORED="usr/bin/.*"
+
+check_space() {
+ local CHECKREQS_DISK_BUILD=3G
+ use debug && CHECKREQS_DISK_BUILD=9G
+ check-reqs_pkg_setup
+}
+
+pkg_pretend() {
+ check_space
+}
+
+pkg_setup() {
+ check_space
+}
+
+src_prepare() {
+ local PATCHES=(
+ # skip broken tests:
+ # - requiring pinned CPython versions (3.8.12, 3.11.7, 3.12.1)
+ # - requiring specific terminal width (COLUMNS don't seem to work)
+ # - other (perhaps failing because of other skipped tests?)
+ "${FILESDIR}/uv-0.1.28-skip-tests.patch"
+ )
+
+ rm crates/uv/tests/pip_compile_scenarios.rs || die
+ default
+}
+
+src_compile() {
+ cd crates/uv || die
+ cargo_src_compile
+}
+
+src_test() {
+ cd crates/uv || die
+ cargo_src_test --no-fail-fast
+}
+
+src_install() {
+ cd crates/uv || die
+ cargo_src_install
+}