summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-25 05:06:34 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-25 05:49:57 +0200
commit49911d25d9e3fb7b16662485c527683f5f1e1dac (patch)
tree42444e6cc7810d7647221b8270641fcda21b70ba /dev-python/uv
parentapp-admin/awscli: Bump to 1.32.113 (diff)
downloadgentoo-49911d25d9e3fb7b16662485c527683f5f1e1dac.tar.gz
gentoo-49911d25d9e3fb7b16662485c527683f5f1e1dac.tar.bz2
gentoo-49911d25d9e3fb7b16662485c527683f5f1e1dac.zip
dev-python/uv: Bump to 0.2.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/uv')
-rw-r--r--dev-python/uv/Manifest2
-rw-r--r--dev-python/uv/uv-0.2.3.ebuild106
2 files changed, 108 insertions, 0 deletions
diff --git a/dev-python/uv/Manifest b/dev-python/uv/Manifest
index 3577d2e46215..1ee73097780d 100644
--- a/dev-python/uv/Manifest
+++ b/dev-python/uv/Manifest
@@ -13,3 +13,5 @@ DIST uv-0.1.45-crates.tar.xz 58017580 BLAKE2B 557abd37f4b436077e59f506f62403b8dc
DIST uv-0.1.45.gh.tar.gz 1105106 BLAKE2B 75b0ce6f21e6f0da8d95be8b035cc817019ad1d1a5227c422412bf8f8b70d3e60298a9355f73dcdc658f43ed5d927bc7e4ed49cc0aaa5ee906ed281d12eb4956 SHA512 b88d0b691d86fd12c830acd06bf7a5b6319b41435ab59a7c8bd975d6876402dba721ef8460fc79a2b515d8737e1848912848bc8751cd28cb4acd148c73e107ad
DIST uv-0.2.2-crates.tar.xz 57993620 BLAKE2B 31a7b73c0954a057a8ddd04d328e1e2b2e00d74b9c5431bbdf0771780a964d49ec8e6dcec00dbf49606c80a01c53117cef76b94bb0a07f15b85056e27d5310e1 SHA512 cccdd9536bbc738c83074eb2e41f1ff329977fe12240c473d8ff4de226dedba97ce9e79998dda25b0f9014e2c8373d80ed87331c0d5314b866b264a011d7c555
DIST uv-0.2.2.gh.tar.gz 1122110 BLAKE2B c65b3925d7798ba5cb43359ef073c673047fec8673f698f5cec3aed50661b08e13a3056345384cae654d2eeabced4c717bac228d77b01ba9522dcac1f18d899e SHA512 9520b8d8c4684b3eedcac686814b7b7d74190760b1d21dd7b3ad99b45954f61437b9ee9583b262ed05b53e9ab0e908e65a9d0e0fc7b3e4bf31c298784d185396
+DIST uv-0.2.3-crates.tar.xz 57931028 BLAKE2B fe6040bb495613a462ff1ae654717b7cf9f8155b7940c0de4e2429b2e764adc59079e8a0aa3f610d8e4e1b219e4693324f33175988328f288844eb39c7e9efd2 SHA512 5557318b621d8ff24af1729c41c07b25c7bc55f680683b5ef827f83c06370585852cf12ca557cc25d93a36e3b6e8fbb275bfe8491185fe8136b407850765cd76
+DIST uv-0.2.3.gh.tar.gz 1123964 BLAKE2B 86f74e01c28dbadfa9ad8b4c2dc109b51d3fb9ba35cf1d5d038856cce03ccbfc2d60f02332a60f74725fd7b39f12ad81cfaf8dac63766b56bc8d385295626530 SHA512 af075da0332ef912c589926e56175bd5c3664f52f4c6f5728624d413247891c919389bb316e237cef1d53aca0725a98609f5fccc5c847e0f96d6d31bd5ee1ab0
diff --git a/dev-python/uv/uv-0.2.3.ebuild b/dev-python/uv/uv-0.2.3.ebuild
new file mode 100644
index 000000000000..609994a07315
--- /dev/null
+++ b/dev-python/uv/uv-0.2.3.ebuild
@@ -0,0 +1,106 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CRATES="
+"
+
+declare -A GIT_CRATES=(
+ [async_zip]='https://github.com/charliermarsh/rs-async-zip;1dcb40cfe1bf5325a6fd4bfcf9894db40241f585;rs-async-zip-%commit%'
+ [pubgrub]='https://github.com/astral-sh/pubgrub;0e684a874c9fb8f74738cd8875524c80e3d4820b;pubgrub-%commit%'
+)
+
+inherit cargo check-reqs
+
+CRATE_P=${P}
+DESCRIPTION="A Python package installer and resolver, written in Rust"
+HOMEPAGE="
+ https://github.com/astral-sh/uv/
+ https://pypi.org/project/uv/
+"
+# pypi sdist misses scripts/, needed for tests
+SRC_URI="
+ https://github.com/astral-sh/uv/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ ${CARGO_CRATE_URIS}
+"
+if [[ ${PKGBUMPING} != ${PVR} ]]; then
+ SRC_URI+="
+ https://dev.gentoo.org/~mgorny/dist/${CRATE_P}-crates.tar.xz
+ "
+fi
+
+# most of the code
+LICENSE="|| ( Apache-2.0 MIT )"
+# crates/pep508-rs is || ( Apache-2.0 BSD-2 ) which is covered below
+# Dependent crate licenses
+LICENSE+="
+ 0BSD Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD-2 BSD ISC MIT
+ MPL-2.0 Unicode-DFS-2016
+"
+# ring crate
+LICENSE+=" openssl"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="test"
+PROPERTIES="test_network"
+
+DEPEND="
+ dev-libs/libgit2:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=virtual/rust-1.77
+ test? (
+ dev-lang/python:3.8
+ dev-lang/python:3.9
+ dev-lang/python:3.10
+ dev-lang/python:3.11
+ dev-lang/python:3.12
+ )
+"
+
+QA_FLAGS_IGNORED="usr/bin/.*"
+
+check_space() {
+ local CHECKREQS_DISK_BUILD=3G
+ use debug && CHECKREQS_DISK_BUILD=9G
+ check-reqs_pkg_setup
+}
+
+pkg_pretend() {
+ check_space
+}
+
+pkg_setup() {
+ check_space
+}
+
+src_prepare() {
+ default
+
+ # https://github.com/vorot93/tokio-tar/pull/23
+ # (fortunately uv already depends on portable-atomic, so we don't
+ # have to fight Cargo.lock)
+ cd "${WORKDIR}/cargo_home/gentoo/tokio-tar-0.3.1" || die
+ eapply "${FILESDIR}/tokio-tar-0.3.1-ppc.patch"
+}
+
+src_compile() {
+ cd crates/uv || die
+ cargo_src_compile
+}
+
+src_test() {
+ cd crates/uv || die
+ cargo_src_test --no-fail-fast
+}
+
+src_install() {
+ cd crates/uv || die
+ cargo_src_install
+}