summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-23 06:20:01 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-23 06:20:01 +0200
commit043f5a50c66385adc4b2c29ad2893aa414914e07 (patch)
tree0798a215b5eab79d32cecc3ff80de32dc639a05c /dev-python/uv
parentdev-python/pydantic-core: Bump to 2.18.2 (diff)
downloadgentoo-043f5a50c66385adc4b2c29ad2893aa414914e07.tar.gz
gentoo-043f5a50c66385adc4b2c29ad2893aa414914e07.tar.bz2
gentoo-043f5a50c66385adc4b2c29ad2893aa414914e07.zip
dev-python/uv: Bump to 0.1.36
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/uv')
-rw-r--r--dev-python/uv/Manifest2
-rw-r--r--dev-python/uv/uv-0.1.36.ebuild111
2 files changed, 113 insertions, 0 deletions
diff --git a/dev-python/uv/Manifest b/dev-python/uv/Manifest
index 463dd133d466..b11c9576ebb1 100644
--- a/dev-python/uv/Manifest
+++ b/dev-python/uv/Manifest
@@ -12,3 +12,5 @@ DIST uv-0.1.33-crates.tar.xz 65532672 BLAKE2B 9e3499eef5cf746287f725ab3f2c2a3544
DIST uv-0.1.33.gh.tar.gz 987063 BLAKE2B 56dfc8e7a1bfb63e0a6278499cb62ef764b4734af14bf01a213b7a11d442d4629d440ac218a4bc2750405c402236b382b07560919211b51c300e07c3c15a9496 SHA512 a05a38f8c1abc572ad2c6823f74a2c076ad267636f5f435f04bf8a02b059c25b82b5fa3b5250137d4077ff721294b34c6d2d57ac0e0c907e211e8cfdcdc8169c
DIST uv-0.1.35-crates.tar.xz 65640928 BLAKE2B 97135ce844dc7af3c424a9b8ea7419b4c392e44a87ab960e59401f0075308001287fc42acd9bc21b300fba3d73fa65e292b55e612b92db05cad183577866a7d8 SHA512 7d862992d2ea92acaa24758cb5425b3053941e1312db1f27ee318049ac68fcd64dc614ba7fa21521cdb9ad11545cc5e8dcc2a2781f0164297229f35768e0776e
DIST uv-0.1.35.gh.tar.gz 1010370 BLAKE2B 0b07f4de6d07969d8721f94b3d21e2797b8425f26db5744f7ee2a90ed3769f3d8245552d8b8db6d8716e45dc88461a9543419191a4b71497019862860d76e728 SHA512 08f224b317d5aa3d9941ee0add791340f41a01e70d2a4e1e9b986e501d666a40e1a04bdeb2120e178bbedb2a91501e608d240a9ac56f509021d6377c278fbfcc
+DIST uv-0.1.36-crates.tar.xz 65852268 BLAKE2B f9dac75dc992d37c54554c25e0ce0895aa017753a6688754acee5b6a99822e0f55923a539fcd67a8d30332abf1d2b2ed333b8b1125eef5061da2d8f57307004b SHA512 c0dd2171416333f8267592c75699fd35f686d04b3b81241e51cbf4b9f8d1e0def54ab9336b2e62e1fb5e40d3ad73146eba7dd6c0093fa23230d23c4fa73d8f74
+DIST uv-0.1.36.gh.tar.gz 1018114 BLAKE2B c57a3362940803df34f45c0dd2bcc176fb4928d1b0c168adc89d150ffb59a39d0fb57b41c063485a7c324a2101b9f4334cf29e175f910122842f893c6be9970a SHA512 39a4ec3b17803a13a53f331185bfb4fa321f9ee2c158828ad9f88aa7214ee72a58a87dcef74eaeac7a1e3a989909f0d50a457431ce22a72703db0e8c3fc4a6c2
diff --git a/dev-python/uv/uv-0.1.36.ebuild b/dev-python/uv/uv-0.1.36.ebuild
new file mode 100644
index 000000000000..793b60d2c541
--- /dev/null
+++ b/dev-python/uv/uv-0.1.36.ebuild
@@ -0,0 +1,111 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CRATES="
+"
+
+declare -A GIT_CRATES=(
+ [async_zip]='https://github.com/charliermarsh/rs-async-zip;1dcb40cfe1bf5325a6fd4bfcf9894db40241f585;rs-async-zip-%commit%'
+ [pubgrub]='https://github.com/astral-sh/pubgrub;c26e485213e39582c6f2e4d45c0328422670e7a7;pubgrub-%commit%'
+)
+
+inherit cargo check-reqs
+
+DESCRIPTION="A Python package installer and resolver, written in Rust"
+HOMEPAGE="
+ https://github.com/astral-sh/uv/
+ https://pypi.org/project/uv/
+"
+# pypi sdist misses scripts/, needed for tests
+SRC_URI="
+ https://github.com/astral-sh/uv/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ ${CARGO_CRATE_URIS}
+"
+if [[ ${PKGBUMPING} != ${PVR} ]]; then
+ CRATE_P=${P}
+ SRC_URI+="
+ https://dev.gentoo.org/~mgorny/dist/${CRATE_P}-crates.tar.xz
+ "
+fi
+
+# most of the code
+LICENSE="|| ( Apache-2.0 MIT )"
+# crates/pep508-rs is || ( Apache-2.0 BSD-2 ) which is covered below
+# Dependent crate licenses
+LICENSE+="
+ 0BSD Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD-2 BSD ISC MIT
+ MPL-2.0 Unicode-DFS-2016
+"
+# ring crate
+LICENSE+=" openssl"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="test"
+PROPERTIES="test_network"
+
+DEPEND="
+ dev-libs/libgit2:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=virtual/rust-1.77
+ test? (
+ dev-lang/python:3.8
+ dev-lang/python:3.9
+ dev-lang/python:3.10
+ dev-lang/python:3.11
+ dev-lang/python:3.12
+ )
+"
+
+QA_FLAGS_IGNORED="usr/bin/.*"
+
+check_space() {
+ local CHECKREQS_DISK_BUILD=3G
+ use debug && CHECKREQS_DISK_BUILD=9G
+ check-reqs_pkg_setup
+}
+
+pkg_pretend() {
+ check_space
+}
+
+pkg_setup() {
+ check_space
+}
+
+src_configure() {
+ local myfeatures=(
+ # from upstream defaults
+ flate2/zlib-ng
+ python
+ pypi
+ git
+ maturin
+ # skip tests that require specific patch version of the interpreter:
+ # python-patch
+ )
+
+ cargo_src_configure --no-default-features
+}
+
+src_compile() {
+ cd crates/uv || die
+ cargo_src_compile
+}
+
+src_test() {
+ cd crates/uv || die
+ cargo_src_test --no-fail-fast
+}
+
+src_install() {
+ cd crates/uv || die
+ cargo_src_install
+}