summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/urlgrabber
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/urlgrabber')
-rw-r--r--dev-python/urlgrabber/Manifest2
-rw-r--r--dev-python/urlgrabber/files/urlgrabber-3.9.1.patch26
-rw-r--r--dev-python/urlgrabber/metadata.xml33
-rw-r--r--dev-python/urlgrabber/urlgrabber-3.10.1.ebuild22
-rw-r--r--dev-python/urlgrabber/urlgrabber-3.9.1-r2.ebuild28
5 files changed, 111 insertions, 0 deletions
diff --git a/dev-python/urlgrabber/Manifest b/dev-python/urlgrabber/Manifest
new file mode 100644
index 000000000000..3f6d9c2ab5a6
--- /dev/null
+++ b/dev-python/urlgrabber/Manifest
@@ -0,0 +1,2 @@
+DIST urlgrabber-3.10.1.tar.gz 83735 SHA256 06b13ff8d527dba3aee04069681b2c09c03117592d5485a80ae4b807cdf33476 SHA512 c44d32b17c5f8984d09ed46ae36b3e05dc69d041820cf979029bc325d8407bbd7e324f264be5886286cd99e123f51affec26638cab6e525f85e2a1c4247462d7 WHIRLPOOL bed47171c6b12de78d430ebaef0f46e5ce166ffa526a19d5a986dc44da5d627f84cfb303b2e2299c8f5af1ee977aad5d9e41a5a886ef26c1986aa53f388f1164
+DIST urlgrabber-3.9.1.tar.gz 72343 SHA256 4437076c8708e5754ea04540e46c7f4f233734ee3590bb8a96389264fb0650d0 SHA512 897f0bd09485c207d735a814fda7cf053c71262e31e87f358c473da770abaf7fd339ae6802df978091889c5d6fe123f74d5386d79c47f93b36cefbc22f44db47 WHIRLPOOL e0fc55804e7565d392a74fc753fcdda1be61c85164fcc00f2acc20270c8c1171e0d49211c04c79ca4e6d056a966a3d8dc48530010201c7748a125dcf54c08544
diff --git a/dev-python/urlgrabber/files/urlgrabber-3.9.1.patch b/dev-python/urlgrabber/files/urlgrabber-3.9.1.patch
new file mode 100644
index 000000000000..bdcc9cb1d465
--- /dev/null
+++ b/dev-python/urlgrabber/files/urlgrabber-3.9.1.patch
@@ -0,0 +1,26 @@
+http://yum.baseurl.org/gitweb?p=urlgrabber.git;a=commitdiff;h=f4e57ece7ded0f7ad83c8a40fe8423fab7812264
+http://yum.baseurl.org/gitweb?p=urlgrabber.git;a=commitdiff;h=89cc380a2a251a1d2d8b91cf6df170fa546597aa
+
+diff --git a/urlgrabber/grabber.py b/urlgrabber/grabber.py
+index f98f423..7b7f979 100644
+--- a/urlgrabber/grabber.py
++++ b/urlgrabber/grabber.py
+@@ -1532,11 +1589,14 @@
+ def _over_max_size(self, cur, max_size=None):
+
+ if not max_size:
+- max_size = self.size
+- if self.opts.size: # if we set an opts size use that, no matter what
+- max_size = self.opts.size
++ if not self.opts.size:
++ max_size = self.size
++ else:
++ max_size = self.opts.size
++
+ if not max_size: return False # if we have None for all of the Max then this is dumb
+- if cur > max_size + max_size*.10:
++
++ if cur > int(float(max_size) * 1.10):
+
+ msg = _("Downloaded more than max size for %s: %s > %s") \
+ % (self.url, cur, max_size)
diff --git a/dev-python/urlgrabber/metadata.xml b/dev-python/urlgrabber/metadata.xml
new file mode 100644
index 000000000000..10b42d6d5af9
--- /dev/null
+++ b/dev-python/urlgrabber/metadata.xml
@@ -0,0 +1,33 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription>
+ A high-level cross-protocol url-grabber.
+
+ Using urlgrabber, data can be fetched in three basic ways:
+
+ urlgrab(url) copy the file to the local filesystem
+ urlopen(url) open the remote file and return a file object (like urllib2.urlopen)
+ urlread(url) return the contents of the file as a string
+
+
+ When using these functions (or methods), urlgrabber supports the following
+ features:
+
+ * identical behavior for http://, ftp://, and file:// urls
+ * http keepalive - faster downloads of many files by using only a single
+ connection
+ * byte ranges - fetch only a portion of the file
+ * reget - for a urlgrab, resume a partial download
+ * progress meters - the ability to report download progress automatically,
+ even when using urlopen!
+ * throttling - restrict bandwidth usage
+ * retries - automatically retry a download if it fails. The number of retries
+ and failure types are configurable.
+ * authenticated server access for http and ftp
+ * proxy support - support for authenticated http and ftp proxies
+ * mirror groups - treat a list of mirrors as a single source, automatically
+ switching mirrors if there is a failure.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/urlgrabber/urlgrabber-3.10.1.ebuild b/dev-python/urlgrabber/urlgrabber-3.10.1.ebuild
new file mode 100644
index 000000000000..86c58670a70d
--- /dev/null
+++ b/dev-python/urlgrabber/urlgrabber-3.10.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for downloading files"
+HOMEPAGE="http://urlgrabber.baseurl.org"
+SRC_URI="http://urlgrabber.baseurl.org/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-python/pycurl[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+# Entire testsuite relies on connecting to the i'net
diff --git a/dev-python/urlgrabber/urlgrabber-3.9.1-r2.ebuild b/dev-python/urlgrabber/urlgrabber-3.9.1-r2.ebuild
new file mode 100644
index 000000000000..e6fa741c3ee2
--- /dev/null
+++ b/dev-python/urlgrabber/urlgrabber-3.9.1-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for downloading files"
+HOMEPAGE="http://urlgrabber.baseurl.org"
+SRC_URI="http://urlgrabber.baseurl.org/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ppc ppc64 x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-python/pycurl[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_prepare_all() {
+ local PATCHES=(
+ "${FILESDIR}"/${P}.patch
+ )
+ distutils-r1_python_prepare_all
+}