summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2016-09-23 09:51:38 -0700
committerBrian Dolbec <dolsen@gentoo.org>2016-09-23 11:52:01 -0700
commit4f2c958c8bedde8a9b9ac5e668da5764ea69fef9 (patch)
tree30f4f62ac3b149fa40ae6cc0d1f35ef0b3d0a573 /dev-python/txaio
parentmedia-sound/pianobar: remove old (diff)
downloadgentoo-4f2c958c8bedde8a9b9ac5e668da5764ea69fef9.tar.gz
gentoo-4f2c958c8bedde8a9b9ac5e668da5764ea69fef9.tar.bz2
gentoo-4f2c958c8bedde8a9b9ac5e668da5764ea69fef9.zip
dev-python/txaio: Fix deps, bump eapi to 6
Package-Manager: portage-2.3.1
Diffstat (limited to 'dev-python/txaio')
-rw-r--r--dev-python/txaio/txaio-2.5.1-r1.ebuild (renamed from dev-python/txaio/txaio-2.5.1.ebuild)22
1 files changed, 15 insertions, 7 deletions
diff --git a/dev-python/txaio/txaio-2.5.1.ebuild b/dev-python/txaio/txaio-2.5.1-r1.ebuild
index f1309ec3dbba..91d12623569a 100644
--- a/dev-python/txaio/txaio-2.5.1.ebuild
+++ b/dev-python/txaio/txaio-2.5.1-r1.ebuild
@@ -2,13 +2,13 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
inherit distutils-r1
-DESCRIPTION="a helper library for writing code unmodified on both Twisted and asyncio"
-HOMEPAGE="https://github.com/tavendo/txaio"
+DESCRIPTION="Compatibility API between asyncio/Twisted/Trollius"
+HOMEPAGE="https://github.com/crossbario/txaio"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
@@ -17,20 +17,28 @@ KEYWORDS="~amd64 ~x86"
IUSE="doc test"
RDEPEND="
- >=dev-python/pep8-1.6.2[${PYTHON_USEDEP}]"
-
+ $(python_gen_cond_dep '>=dev-python/trollius-2.0[${PYTHON_USEDEP}]' python2_7)
+ $(python_gen_cond_dep '>=dev-python/futures-3.0.3[${PYTHON_USEDEP}]' python2_7)
+"
DEPEND="app-arch/unzip
dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/sphinx-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/sphinxcontrib-spelling-2.1.2[${PYTHON_USEDEP}]
+ >=dev-python/sphinx_rtd_theme-0.1.9[${PYTHON_USEDEP}]
dev-python/alabaster[${PYTHON_USEDEP}]
)
test? ( >=dev-python/pytest-2.6.4[${PYTHON_USEDEP}]
>=dev-python/pytest-cov-1.8.1[${PYTHON_USEDEP}]
~dev-python/mock-1.3.0[${PYTHON_USEDEP}]
>=dev-python/tox-2.1.1[${PYTHON_USEDEP}]
- )"
+ >=dev-python/pep8-1.6.2[${PYTHON_USEDEP}]
+ >=dev-python/pyenchant-1.6.6[${PYTHON_USEDEP}]
+ )
+"
src_prepare() {
+ default_src_prepare
# Take out failing tests known to pass when run manually
# we certainly don't need to test "python setup.py sdist" here
rm "${S}/test/test_packaging.py" || die