summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-17 08:17:28 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-17 08:17:44 +0200
commitb091d6a6ad5c70f8d72ab62932bfbbdcb090f2dd (patch)
tree24e9e00eebd8ff5f633416f75eb94ff70ee593be /dev-python/twython
parentdev-python/requests-oauthlib: Use pytest for nice deselect (diff)
downloadgentoo-b091d6a6ad5c70f8d72ab62932bfbbdcb090f2dd.tar.gz
gentoo-b091d6a6ad5c70f8d72ab62932bfbbdcb090f2dd.tar.bz2
gentoo-b091d6a6ad5c70f8d72ab62932bfbbdcb090f2dd.zip
dev-python/twython: Bump to 3.9.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/twython')
-rw-r--r--dev-python/twython/Manifest1
-rw-r--r--dev-python/twython/twython-3.9.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/twython/Manifest b/dev-python/twython/Manifest
index 5dd6430e9891..ba0c33608822 100644
--- a/dev-python/twython/Manifest
+++ b/dev-python/twython/Manifest
@@ -1 +1,2 @@
DIST twython-3.7.0.gh.tar.gz 373183 BLAKE2B a84e10c1d61736af3e93f265d92104dac15d5f7a43d7fbdce4e8c58b641f671a1c4c10f44c5b6d6ce9f0646860d35c14414b17e84daeb74f6e2c8871207b6fd4 SHA512 33eb35ea811ec1964fcd51fad54ba53d60e6caf3b5b7d11ae138f7228be9fb1eca7a02b1c6699a62cc2f6c39e035cb5a28f53ef67a98d019cdf91c9874867871
+DIST twython-3.9.1.gh.tar.gz 372933 BLAKE2B 3db7f37e284ec83546e4f93a23e34c21ce9853e6206b62353e36b738ba591acadc55fd3dbbdf8cf7d74e63ab9966b9cdc7f49c5caa06e165bb7107b350509835 SHA512 e64d623dfa7ba2e81e09f9d8e784851b44201493d128ec576c4b5a9abc88debf1ca78f8a12933e0cd0a6b495012fa951bb62ea5d92db11186b37747b8576174f
diff --git a/dev-python/twython/twython-3.9.1.ebuild b/dev-python/twython/twython-3.9.1.ebuild
new file mode 100644
index 000000000000..88ff3fa034fa
--- /dev/null
+++ b/dev-python/twython/twython-3.9.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="An easy way to access Twitter data with Python"
+HOMEPAGE="https://github.com/ryanmcgrath/twython"
+SRC_URI="
+ https://github.com/ryanmcgrath/twython/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/requests-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-oauthlib-0.4.0[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( dev-python/responses[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # tests are largely unmaintained and outdated
+ tests/test_core.py::TwythonAPITestCase::test_get_lastfunction_header_should_return_header
+ tests/test_core.py::TwythonAPITestCase::test_request_should_handle_400_for_missing_auth_data
+ tests/test_core.py::TwythonAPITestCase::test_request_should_handle_400_that_is_not_auth_related
+ tests/test_core.py::TwythonAPITestCase::test_request_should_handle_401
+ tests/test_core.py::TwythonAPITestCase::test_request_should_handle_rate_limit
+ )
+ epytest ${deselect[@]/#/--deselect }
+}