summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-03 17:40:06 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-03 17:41:40 +0300
commit0fdf22864692e688fc7ea5724c5cbac4d444985d (patch)
tree3b721330cf222a1f149dbc062305fd2413247b4f /dev-python/tomli
parentdev-python/cfn-lint: enable py3.10 (diff)
downloadgentoo-0fdf22864692e688fc7ea5724c5cbac4d444985d.tar.gz
gentoo-0fdf22864692e688fc7ea5724c5cbac4d444985d.tar.bz2
gentoo-0fdf22864692e688fc7ea5724c5cbac4d444985d.zip
dev-python/tomli: add 1.2.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/tomli')
-rw-r--r--dev-python/tomli/Manifest1
-rw-r--r--dev-python/tomli/tomli-1.2.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/tomli/Manifest b/dev-python/tomli/Manifest
index 76649fa27b62..7dd92b5d4760 100644
--- a/dev-python/tomli/Manifest
+++ b/dev-python/tomli/Manifest
@@ -1 +1,2 @@
DIST tomli-1.0.4.gh.tar.gz 120508 BLAKE2B bd75568315b405598578b395ec0e20b7f37e9ceee58f145cda8adaf58a3fa549cd35902650f5b2aa84b764ab32eac8a21d3ffd94c0c4c43eab3c3a0b49203a71 SHA512 e30e06ea805c94359596c3d6db82464ccafcdde0172cae12d62c889c70986159b3198cf465183854bef1b048c21e487c2b0dad2825e2477d363885e749b238ee
+DIST tomli-1.2.1.gh.tar.gz 122701 BLAKE2B d0280bb81a6e931a175c6ef2c58b4f36b1237f99a73331cbb95f98b9e68a98a4c6a635aa12751ac46492c2b1a06a821f1ae70cd0c36f268998488e824f3e577c SHA512 34f9529b137331b0ae03ac99170b3f6509847356594be14166bae306ea4fbbddff808ffe0c48d05434f72d223a2f35b511675217053029d287725b7142fbd089
diff --git a/dev-python/tomli/tomli-1.2.1.ebuild b/dev-python/tomli/tomli-1.2.1.ebuild
new file mode 100644
index 000000000000..1bced1acc7cd
--- /dev/null
+++ b/dev-python/tomli/tomli-1.2.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="A lil' TOML parser"
+HOMEPAGE="
+ https://pypi.org/project/tomli/
+ https://github.com/hukkin/tomli/"
+SRC_URI="
+ https://github.com/hukkin/tomli/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+BDEPEND="
+ test? ( dev-python/python-dateutil[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # we don't use pyproject.toml to avoid circular deps
+ cat > setup.py <<-EOF || die
+ from setuptools import setup
+ setup(name="tomli", version="${PV}", packages=["tomli"], package_data={"": ["*"]})
+ EOF
+
+ distutils-r1_src_prepare
+}